file [Solved] UTP in Modelio 2.2

7 years 1 month ago - 7 years 1 month ago #1007 by mauro
Hi ebr,
I'm new with Modelio and I installed yesterday the last version 2.2.0. So, I put the "UTP_2.0.02.jmdac" file in "mdastore" directory and then I imported the example through File->import model.
In the log I have this exception:
Warning: Spoiler! [ Click to expand ]


I'm following the guide at forge.modelio.org/projects/utp-user-manual-english/wiki/

Please Log in or Create an account to join the conversation.

7 years 1 month ago #1008 by ebr
Hi mauro,

Before the import of the model, have you deployed the UTP module in your project by using Extensions -> Install a module... ?
In order to check the list of deployed modules in your model, use Extensions -> Activate/Desactivate modules ...

Hoping it helps,

Best Regards,

EBR

Please Log in or Create an account to join the conversation.

7 years 1 month ago - 7 years 1 month ago #1014 by mauro

ebr wrote: Hi mauro,

Before the import of the model, have you deployed the UTP module in your project by using Extensions -> Install a module... ?
...


Yes I have, I can also use the functions of UTP module .
Infact, I can create the test package automatically through the UTP function and then I can create the Test Component... the only one that I can't use is the Test Context.

I tried again the ATM example and until the use of Test Context option of UTP module in the log there aren't exceptions, after I get:
Warning: Spoiler! [ Click to expand ]


I hope that it helps to find the bug (if there is one...)

Regards,
m

Please Log in or Create an account to join the conversation.

7 years 1 month ago - 7 years 1 month ago #1015 by mauro
I'm trying with a fresh install of modelio and when I install the utp module I get an error:
Deploy U2TP.ramc model component...
C:\[workspace_path]\test\mda\UTP\ramc\U2TP.ramc (File not found)
the log is:
Warning: Spoiler! [ Click to expand ]

Please Log in or Create an account to join the conversation.

7 years 1 month ago #1017 by ebr
Hi mauro,

So does the file C:\Documents and Settings\Administrator\Desktop\ws_modelio\test\mda\UTP\ramc\U2TP.ramc exist or not?
If it does not exist could you redeploy the UTP Module and see if the file exists and if UTP types are present in your project.

I guess you are not able to use the TestContext because the UTP types are not present in your project (fig 4 of the ATM tutorial).

Hoping it helps,

EBR.

PS: What is your OS? Your versions of Modelio and UTP?

Please Log in or Create an account to join the conversation.

7 years 1 month ago #1018 by mauro
Hi ebr,
you're right, the UTP types are not present into the project (I attach an image to show you my situation)



but the file U2TP.ramc is in right place.
I get the error only the first time I try to install the module.

My specs are:
Windows XP (32bit)
Modelio Version: 2.2.0 Build Id: 2.2.0.201206151710
UTP 2.0.02
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: tmachmebr
Time to create page: 0.139 seconds
^ Back to Top