file [Solved] web publisher error

7 years 2 months ago #888 by bgra
Hi,

I use Modelio
The Open Source modeling environment
Version 2.1.1
Build Id: 2.1.1.201203281815
Core Id: 20120323
and WebModelPublisher_1.0.04.jmdac

When I try to generate a web site from my model, I have the following error (see attached file) :
Error encouterd in node 1 of template Explorer:null

To generate a web site, I did a right click on "all diagrams" in diagram view, then "Web Model Publisher" -> Generate.

Does someone know what's happened ?

Bernard
Attachments:

Please Log in or Create an account to join the conversation.

7 years 2 months ago #889 by chm
Hi bgra,

this looks like a bug to me, the generate command shouldn't be available when selecting "all diagrams".

You should launch it on a Package instead, in the Model view.

Hope this helps...

Please Log in or Create an account to join the conversation.

7 years 2 months ago #891 by bgra
Hi,

Thanks for your answer, I just tried.

I did a deployment diagram

Select my "root" package in Model view down to the diagram view
right click
web model publisher-> generate

It generates html pages with UML element but the deployment diagram is not available in these pages :(

Another idea ? :)

Bernard

Please Log in or Create an account to join the conversation.

7 years 2 months ago #892 by osl
Have you tried on a simple model?

Like:


Go pro
Attachments:

Please Log in or Create an account to join the conversation.

7 years 2 months ago #893 by bgra
Hi,

Thanks for your picture, I found the problem : the diagram did not belong to the root package in Model view. After a drag and drop of the diagram from the Diagram view to the Model everythings are ok.

Thanks again

Bernard

Please Log in or Create an account to join the conversation.

Moderators: tmachmebr
Time to create page: 0.146 seconds
^ Back to Top