lock [Solved] Document Publish for BPMN Behaviours

7 years 4 months ago #760 by chm
Hello Biggle,

a BPMN template has been added in Document Publisher 3.2.03 (Modelio 2.1.1), is it the version you are using ? It also fixes a problem involving SmartFinder nodes & BPMN elements...

I'm not sure it is already available for download on the store, but our support team could probably send it to you if needed.

Hope this helps!
The topic has been locked.
7 years 4 months ago #761 by Biggle
Hi,

I have Modelio 2.1.1 but my Document Publisher version is only 3.1.4.8008.

It does look like an issue with the Smart Finder, it can't seem to navigate below the BPMNBehaviour element.

How do I get the update from the Support team?

Regards

Cheers
Biggle
The topic has been locked.
7 years 4 months ago #763 by pan
Hi Biggle,

You can download the latest version (3.2.03) of Document Publisher on the Store ( Document Publisher page ).

BR
The topic has been locked.
7 years 4 months ago #767 by Biggle
Thanks,

After I've upgraded several of the documents no longer generate. A blank error dialogue displays




I have tried recreating the template files and using different styles as well, in some instances Modelio crashes without any feedback.

Anywhere I can have a look at a log file to find out what's going on?

Regards

Cheers
Biggle
Attachments:
The topic has been locked.
7 years 4 months ago - 7 years 4 months ago #770 by chm
If i remember correctly, you are using custom templates. It might be the cause of the error, but i'm only guessing yet.

First of all, you should check you have the same version installed for DocumentPublisher & TemplateEditor.

Then, package your templates again.

Last, you should edit the Documents from your model to make sure they specify a valid template...

I don't think you can find anything usefull in the log, but you can try launching Modelio with the option -consoleLog (requires editing your shortcut).
The topic has been locked.
7 years 4 months ago #773 by Biggle
Yes, this is the process I am going through.

I have checked and both versions of the DocumentPublisher and TemplateEditor modules are the same.

It happens using both my custom template and the ones provided (I was surprised to find it deleted the existing templates and styles I had, lucky I had a backup).

In the console I can't see anything surprising when the blank error message is displayed (I didn't get a chance to try with -debug).

When the application crashes I do notice a Java Stack Trace printed in the console immediately before it closes. Any clues on how to capture it's output so I can put it here?

Also, I can revert the modules to the previous version (same issue with deleting templates and styles) and everything works as expected.

My next step might be to remove/re-install Modelio, but I don't know what that might achieve as the modules are specific to a project.

Cheers
Biggle
The topic has been locked.
Moderators: tmachmebr
Time to create page: 0.146 seconds
^ Back to Top