lock [Solved] Document Publish for BPMN Behaviours

7 years 4 months ago - 7 years 3 months ago #759 by Biggle
Hi,

I am struggling to create a Template that will successfully export/document BPMN Behaviours from the model. I also can't find any suitable examples in the ones provided where BPMN elements are being used in the Template Editor.

Has anyone got this working, or does anyone know if this is possible?

Cheers
Biggle

Cheers
Biggle
The topic has been locked.
7 years 4 months ago #760 by chm
Hello Biggle,

a BPMN template has been added in Document Publisher 3.2.03 (Modelio 2.1.1), is it the version you are using ? It also fixes a problem involving SmartFinder nodes & BPMN elements...

I'm not sure it is already available for download on the store, but our support team could probably send it to you if needed.

Hope this helps!
The topic has been locked.
7 years 4 months ago #761 by Biggle
Hi,

I have Modelio 2.1.1 but my Document Publisher version is only 3.1.4.8008.

It does look like an issue with the Smart Finder, it can't seem to navigate below the BPMNBehaviour element.

How do I get the update from the Support team?

Regards

Cheers
Biggle
The topic has been locked.
7 years 4 months ago #763 by pan
Hi Biggle,

You can download the latest version (3.2.03) of Document Publisher on the Store ( Document Publisher page ).

BR
The topic has been locked.
7 years 4 months ago #767 by Biggle
Thanks,

After I've upgraded several of the documents no longer generate. A blank error dialogue displays




I have tried recreating the template files and using different styles as well, in some instances Modelio crashes without any feedback.

Anywhere I can have a look at a log file to find out what's going on?

Regards

Cheers
Biggle
Attachments:
The topic has been locked.
7 years 4 months ago - 7 years 4 months ago #770 by chm
If i remember correctly, you are using custom templates. It might be the cause of the error, but i'm only guessing yet.

First of all, you should check you have the same version installed for DocumentPublisher & TemplateEditor.

Then, package your templates again.

Last, you should edit the Documents from your model to make sure they specify a valid template...

I don't think you can find anything usefull in the log, but you can try launching Modelio with the option -consoleLog (requires editing your shortcut).
The topic has been locked.
Moderators: tmachmebr
Time to create page: 0.195 seconds
^ Back to Top