file [Modelio 4.0] problem to run a module in a jython script

2 months 5 days ago #5890 by cael
Hi,

I want to generate the HTML documentation using WebModelPublisher module from a command line. I understood that the way to do it is to write a jython script invoked on the command line.
So I have a shell script that runs Modelio and executes a jython script, that works perfectly.
In my jython script I’m able to get the IPeerModule instance of the WebModelPublisher, but I have 2 issues to run it:
- I want to set the parameters values, so I assume I should use:
getConfiguration().setParameterValue(java.lang.String key, java.lang.String value)
But how can I get the keys ? I tried:
getConfiguration().getParameters().keySet()
but it returns an empty list.
- And how can I run the module ? Which method can I use to do it ?

Thanks! :-)

Please Log in or Create an account to join the conversation.

2 months 4 days ago - 2 months 4 days ago #5893 by osl
Hi Cael,

The WebModulePublisher module cannot be run in command line with a jython script.

Which services of a module are accessible in command line is for its author to decide, in this case: Modeliosoft.
WebModelPublisher is a free module, but it is not an open-source one.

To automate the generation of documents from a model, you should have a look at Document Publisher, which is the commercial solution.

I have recorded an evolution request for you in the Community forge, although I can't guarantee it will be taken into account:
http://forge.modelio.org/issues/397

Best regards

Go pro

Please Log in or Create an account to join the conversation.

Moderators: tmachmebr
Time to create page: 0.031 seconds
^ Back to Top