file Moving from the commercial Togaf module to the Free version

4 years 9 months ago #3087 by cde
Hi Kevin Smith,

The problem comes from the fact that the Togaf Architect by Modeliosoft is redeployed in the modules catalog when reopening your Project.
To fix this, try the following steps :

1. Open your project.
2. Add the Togaf Architect (open source) module to the catalog.
3. Deploy the Togaf Architect module in your project.

Hope this helps,
cde.

Please Log in or Create an account to join the conversation.

4 years 9 months ago #3094 by KevinSmith
Hi,

It's what i did but i have exactly the same error. :(

How can i remove all things related to the commercial version ?
Remove it from the catalog and add the free version seems to be not enough.

Regards,

Please Log in or Create an account to join the conversation.

4 years 9 months ago #3099 by cde
Hi,

The problem is that when you open the project containing the Togaf Architect by Modeliosoft (commercial) it automatically add it to the catalog...
That's why you have to re-add the Togaf Architect open source to the calatog just after opening the project...

If it still doesn't work, try this work around:
1. Create a new project with the open source edition and install the Togaf Architect open source in it.
2. Righ-click on the work model root and launch the 'Import a model' command, then import the content of your commercial project.

Hope this helps,
cde.

Please Log in or Create an account to join the conversation.

4 years 9 months ago #3101 by KevinSmith
Thank you for your help.

I tried to follow your procedure without success. I created a new projet but I get exactly the same error when i tried to add the free Togaf component. This projet was empty.

Is there a setting on the free Modelio version to force the free Togaf component ?

Regards,

Please Log in or Create an account to join the conversation.

4 years 9 months ago #3102 by cde
Hi,

Can you post a screenshot of the 'Modules' tab of your new project ?

Meanwhile, you can retry the work around by first making sure that the 'Togaf Architect by Modeliosoft' module (commercial) is no more present in the catalog.

1. Launch the 'Configuration\Modules catalog' command and remove all Togaf modules from the catalog.
2. Add the Togaf Architect open source to the catalog.
3. Create a brand new project with the open source edition and install the Togaf Architect open source in it.
4. Check that its really the Togaf open source deployed in the project (in the 'Project's modules' frame, the Open source module is named 'Togaf Architect' and the commercial one 'Togaf Architect by Modeliosoft')
5. Righ-click on the work model root and launch the 'Import a model' command, then import the content of your commercial project.

Hope this helps,
cde.

Please Log in or Create an account to join the conversation.

4 years 9 months ago #3105 by KevinSmith
Hi,

Thank you for your help cde.

I created a brand new project with the open source edition and I installed the Togaf Architect open source as you said but i got the same "link error...".

I finally remove the modelio open source directory containing modelio.exe et reextract it from "modelio-open-201405191231-win32.win32.x86_64.zip".

I can open my Modelio project without any error now. The free 'TogafArchitect' module appears installed in the project configuration with the Started status. Everything seems fine.

Unfortunately, I still have a problem when I open my togaf diagram. Modelio doesn't seem to recognize them a Togaf diagram. By exemple, process elements are displayed as "No image" and i have nothing in the toolbar diagram.

I tried to add the "event diagram" stereotype on a event diagram without success. "No image" is displayed with no elements in the diagram toolbar.

I can add a Togaf diagram without problem on my Modelio Project. The problem is on existing Togaf diagrams. I tried to import it on a brand new project but I have the same problem.

Do you have any idea to fix it ?

Thank you.

Regards,

Please Log in or Create an account to join the conversation.

Moderators: tmachmebr
Time to create page: 0.049 seconds
^ Back to Top