file Moving from the commercial Togaf module to the Free version

4 years 7 months ago - 4 years 7 months ago #3085 by KevinSmith
Hello,

I used the Modelio commercial version and had to come back to the Free/Community version for a project.

I have a problem with the Togaf Architect module. The message "No licence available for the "TogafArchitect" module" is displayed when i open my project (see project_opening.png)

The Togaf Architect is displayed as "Not available" (see list_modules.png).

So, I removed the Togaf module from the project and from the module Catalog. After that I add the free version in the module catalog without problem. I finally tried to add it in the project configuration but i got the message "Linkage error thrown while initializing the 'TogafArchitect' module (see error_Togaf_module_adding.png)


The free version of the Togaf module added is located in the mdastore directory named TogafArchitect_3.1.01.jmdac with a size of 3424Ko. I tried to download it from www.modeliosoft.com/fr/modelio-store/mod...ect-open-source.html . The file has the same size. Unfortunately, i had the same error.

Could you please tell me what I missed when adding it ?

Thank you for your help
Attachments:

Please Log in or Create an account to join the conversation.

4 years 7 months ago #3087 by cde
Hi Kevin Smith,

The problem comes from the fact that the Togaf Architect by Modeliosoft is redeployed in the modules catalog when reopening your Project.
To fix this, try the following steps :

1. Open your project.
2. Add the Togaf Architect (open source) module to the catalog.
3. Deploy the Togaf Architect module in your project.

Hope this helps,
cde.

Please Log in or Create an account to join the conversation.

4 years 7 months ago #3094 by KevinSmith
Hi,

It's what i did but i have exactly the same error. :(

How can i remove all things related to the commercial version ?
Remove it from the catalog and add the free version seems to be not enough.

Regards,

Please Log in or Create an account to join the conversation.

4 years 7 months ago #3099 by cde
Hi,

The problem is that when you open the project containing the Togaf Architect by Modeliosoft (commercial) it automatically add it to the catalog...
That's why you have to re-add the Togaf Architect open source to the calatog just after opening the project...

If it still doesn't work, try this work around:
1. Create a new project with the open source edition and install the Togaf Architect open source in it.
2. Righ-click on the work model root and launch the 'Import a model' command, then import the content of your commercial project.

Hope this helps,
cde.

Please Log in or Create an account to join the conversation.

4 years 7 months ago #3101 by KevinSmith
Thank you for your help.

I tried to follow your procedure without success. I created a new projet but I get exactly the same error when i tried to add the free Togaf component. This projet was empty.

Is there a setting on the free Modelio version to force the free Togaf component ?

Regards,

Please Log in or Create an account to join the conversation.

4 years 7 months ago #3102 by cde
Hi,

Can you post a screenshot of the 'Modules' tab of your new project ?

Meanwhile, you can retry the work around by first making sure that the 'Togaf Architect by Modeliosoft' module (commercial) is no more present in the catalog.

1. Launch the 'Configuration\Modules catalog' command and remove all Togaf modules from the catalog.
2. Add the Togaf Architect open source to the catalog.
3. Create a brand new project with the open source edition and install the Togaf Architect open source in it.
4. Check that its really the Togaf open source deployed in the project (in the 'Project's modules' frame, the Open source module is named 'Togaf Architect' and the commercial one 'Togaf Architect by Modeliosoft')
5. Righ-click on the work model root and launch the 'Import a model' command, then import the content of your commercial project.

Hope this helps,
cde.

Please Log in or Create an account to join the conversation.

Moderators: tmachmebr
Time to create page: 0.039 seconds
^ Back to Top