file [Solved] Import UPDM Profile?

6 years 6 months ago #1515 by barbe.rousse
Hi Dave,

Did you try to use the XMI "import profile" byright clicking on the "LocalModule" as explain here .

Hoping it helps,

BR

Please Log in or Create an account to join the conversation.

6 years 6 months ago #1516 by DaveP20175
Thanks, BR.

I did try your suggestion; I get an error message "Failed: file content is not recognized as a valid profile." I'm hoping there is a simple fix by editing the XMI, which is not generated from Modelio. I have an impression Modelio only imports profiles previously exported from Modelio, but that may be incorrect. The source for my import is direct from the OMG site:
www.omg.org/spec/UPDM/20120301/UPDM_Profile.xmi

Dave

Please Log in or Create an account to join the conversation.

6 years 6 months ago #1517 by ebr
Hi Dave,

Of course it is easier to import something you exported ;).

I will take a look at it and will keep you in touch.

Regards,

EBR

Please Log in or Create an account to join the conversation.

6 years 6 months ago #1518 by DaveP20175
Hi, EBR

I did some more investigating, found the log file. Its content:

[1/29/13 12:02:24 PM]: The selected file is not EMF 2.1 compatible.
[1/29/13 12:02:24 PM]: C:\modelio\myImports\http:\www.omg.org\spec\UML\20101101\StandardProfileL2.xmi (The filename, directory name, or volume label syntax is incorrect)
[1/29/13 12:02:24 PM]: The following EMF error occurred during model import : org.xml.sax.SAXParseExceptionpublicId: file:/C:/Users/dave/modelio/workspace/UPDM/mda/XMI/temp/UPDM.uml; systemId: file:/C:/Users/dave/modelio/workspace/UPDM/mda/XMI/temp/UPDM.uml; lineNumber: 1; columnNumber: 1; Premature end of file. (file:/C:/Users/dave/modelio/workspace/UPDM/mda/XMI/temp/UPDM.uml, 1, 1)

Note the second line. It is looking for an import of an OMG file in the installation directory for Modelio BUT apparently incorporating an http: pointer to the OMG site for one of the UML specifications.

I have imported the UPDM xmi (my source file) to c:\modelio\myImports because I needed to edit it to update the OMG pointers to the StandardProfileL2.xmi - they have moved since the original updm was generated. It seems strange to me that Modelio would look in my directory structure for a file referenced as http ... is this normal for Modelio?

Thanks for looking.

Dave

Please Log in or Create an account to join the conversation.

6 years 6 months ago #1521 by DaveP20175
Further exploration seems to indicate this is, in part, the same problem as Anomalie #83.

Dave

Please Log in or Create an account to join the conversation.

6 years 6 months ago - 6 years 6 months ago #1525 by ebr
Hi Dave,

You are right right several issue occur during the UPDM import including #83.
While waiting for a fix for these issue, I attached a modified version of UPDM profile which is importable under Modelio.

Hoping it helps,

EBR
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: tmachmebr
Time to create page: 0.043 seconds
^ Back to Top