file Installation/Starting on Debain (wheezy) failed - JVM terminated. Exit code=1

6 years 9 months ago #988 by irmhild
Hi,

I tried to install and start modelio
Modelio 2.2 - Linux 64bits (158 MB) and
Modelio 2.1.1 - Linux 64-bit (177.93 MB).

With both versions starting modelio failed with

JVM terminated. Exit code=1
/home/irmhild/Programme/modelio/jre/bin/java
-jar /home/irmhild/Programme/modelio//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /home/irmhild/Programme/modelio/modelio
-name Modelio
--launcher.library /home/irmhild/Programme/modelio//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505/eclipse_1407.so
-startup /home/irmhild/Programme/modelio//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.overrideVmargs
-exitdata 10002
-vm /home/irmhild/Programme/modelio/jre/bin/java
-vmargs
-jar /home/irmhild/Programme/modelio//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar

I had installed all necessary libaries, exactly
libc6: 2.13-33
libatk: 2.5.3-1
libcairo2: 1.12.2-2
libgtk2: -> libgtk-3-0 3.4.2-2
libglib2: 2.32.3-1
libwebkit: 1.2.7-0+squeeze1
libxtst6: 2:1.2.1-1
stdc++ 6: ?=libstdc++6 4.7.1-2

So: where are the problem? What could I do/try?

thanks in advance
Irmhild

Please Log in or Create an account to join the conversation.

6 years 9 months ago #991 by ffe
Do you use the "modelio.sh" to launch Modelio ?

Could you attach the modelioj.log (the log file is stocked in ${HOME}/.modelio/2.2 directory) ?

Please Log in or Create an account to join the conversation.

6 years 9 months ago #992 by irmhild
yes, a long time *after* writing my question, I tried sh and it works! :-)

But :-( now I get the next problem: I want to draw BMP-diagrams but I didn't get them in the diagram list. What could I do?

Please Log in or Create an account to join the conversation.

6 years 9 months ago #993 by osl
Hi there,

I suppose you meant a BPMN diagram, right?

That list depends on what element is selected.

BR

Go pro

Please Log in or Create an account to join the conversation.

6 years 9 months ago #994 by irmhild
hi,

yes of course, I meant a BPMN diagram.
What did I do?
- I create a new project, named "test"
- in the "diagram" view I choose "create a diagram" or the wizard
=> there only Class, Deployment, Object and Use case diagram available,
but in all screeshots (in tutorial etc.) are a lot of more types.

So: what can I do or where can I read more?

Thanks a lot!
ir

Please Log in or Create an account to join the conversation.

6 years 9 months ago - 6 years 9 months ago #995 by osl
Try creating your diagram using the toolbar button while the focus is in the Model view, or from the model view context menu. This will give you more choice:


Go pro
Attachments:
The following user(s) said Thank You: irmhild

Please Log in or Create an account to join the conversation.

Moderators: oslcde
Time to create page: 0.137 seconds
^ Back to Top