file After run Modelio i get alert java.lang.NullPointerException java.lang.NullPoint

1 year 2 months ago #6273 by JosefMinar
Hello,
after i run modelio, i get alert

Internal Error:
java.lang.NullPointerException


Java(TM) SE Runtime Environment (build 1.8.0_271-b09)
Java HotSpot(TM) 64-Bit Server VM (build 25.271-b09, mixed mode)

MacOS Big Sur 11.0.1

Modelio 4.1.0


Modelio.ini
-startup
../Eclipse/plugins/org.eclipse.equinox.launcher_1.5.100.v20180827-1352.jar
--launcher.library
../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.800.v20180827-1352
-clearPersistedState
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_271.jdk/Contents/Home/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.8
-Xms512m
-Dpython.console.encoding=UTF-8
-Dosgi.requiredJavaVersion=1.8
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts

Can you help me please?

Thank you very much,

BR

Minář

Please Log in or Create an account to join the conversation.

1 year 2 weeks ago #6290 by jimjohan
Unfortunately, I had a similar error message with my setup after upgrading to Big Sur. Hopefully others will offer some suggestions too but here are a few things I found. Within the app contents, there are two configuration files.

First, there is the modelio.ini in the Eclipse folder. I found by adding the configuration line suggested in a Mac OS Big Sur Eclipse forum at stackoverflow.com/questions/62647625/not...pse-on-macos-big-sur that I can at least get Modelio to "start" but only to the NullPoint error.

Second, under the Contents main folder there is the info.plist file, which you reference above. Making modifications to this file do cause some changes. Note, alternatively if one starts modelio from a command line by navigating to the MacOS file and running ./modelio one can add the same kind of modifiers as listed in the info.plist file.

Trying to do some troubleshooting I found right where the errors starts in my log file, or if I run it from a command line, where it shows up there. Note I replaces my user name with <me> below. The last line is the first indication of an SWT NullPointer error.

2021-01-09 04:16:03,740 INFO l.w.PluginLogger - Changing log level from ERROR to INFO
2021-01-09 04:16:03,787 INFO LogService - Modelio by modelio.org
2021-01-09 04:16:03,799 INFO LogService - Modelio version : '4.1.00'
2021-01-09 04:16:03,799 INFO LogService - Modelio runtime data path : '/Users/<me>/.modelio/4.1'
2021-01-09 04:16:03,799 INFO LogService - Modelio module catalog path: '/Users/<me>/.modelio/4.1/modules'
2021-01-09 04:16:03,799 INFO LogService - Modelio macro catalog path: '/Users/<me>/.modelio/4.1/macros'
2021-01-09 04:16:03,800 INFO LogService - Instance location: file:/Users/<me>/.modelio/4.1/opensource-cache/data/
2021-01-09 04:16:03,800 INFO LogService - Command line arguments = '-clearPersistedState -vm /Library/Java/JavaVirtualMachines/jdk1.8.0_271.jdk/Contents/Home/bin/ '
2021-01-09 04:16:04,053 INFO LogService - Trusted server certificates store is '/Users/<me>/.modelio/4.1/servercerts.db'
2021-01-09 04:16:05,737 INFO LogService - SWAP is ENABLED
2021-01-09 04:16:06,270 INFO LogService - Changing workspace to: /Users/<me>/modelio/workspace
2021-01-09 04:16:07,610 INFO LogService - Running batch: project=null create=false workspace=null
2021-01-09 04:16:46,971 ERROR LogService - Unhandled exception caught by SWT: java.lang.NullPointerException

I believe that after it starts with elements related to Eclipse (using the modelio.ini file) it then "switches" to some modelio unique code and somehow does not know how to get to the java virtual machine.

Does anyone have insight into what could be done to help modelio know where the java virtual machine is?

I have some old working logs before I did an upgrade and right at the point listed above it worked as shown below.

2020-12-01 09:24:26,014 INFO LogService - Running batch: project=null create=false workspace=null
2020-12-01 09:24:32,025 INFO LogService - Opening project 'CubeSat_Academic'

Thank you

Please Log in or Create an account to join the conversation.

Moderators: cde
Time to create page: 0.035 seconds
^ Back to Top