times libwebkitgtk-1.0-0 dependency on Pop!_OS

1 year 2 days ago #5916 by johhnry
Hi everyone,

I am trying to install the latest version of Modelio with the .deb package for ubuntu : modelio-open-source4.0_4.0.1_ubuntu_amd64.deb
I am running on Pop!_OS 20.04 (similar to ubuntu) and when I run

sudo dpkg -i modelio-open-source4.0_4.0.1_ubuntu_amd64.deb

I get the error that the package libwebkitgtk-1.0-0 is not installed.

However, I have libwebkit2gtk-4.0-37 installed on my machine.

Where is the problem here?

Thanks in advance

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago #5943 by killerbee
The problem is that with Ubuntu 20.04 libwebkit1gtk was removed from repos, either modelio shifts to libwebkit2gtk or they package the version1 into the deb.... Or they would provide an appimage

Bummer for Ubunut 20.04 so far...

Please Log in or Create an account to join the conversation.

5 months 3 weeks ago - 5 months 3 weeks ago #6270 by JosephNguyen
It's not a clear solution, but it is what I've done to install Modelio, hope can help you guys

1. Download the official package from Modelio site, in my case is version 4.1
2. There are a lot of required libraries as www.modelio.org/downloads-links/requirements.html . You can install these in advance, or just try installing Modelio and it will tell you which package is missing.
3. sudo dpkg -i modelio-open-source_4.1.0_ubuntu_amd64.deb
If error of missing packages appears, do as following
4. sudo vi /etc/apt/sources.list
5. Add 'deb cz.archive.ubuntu.com/ubuntu bionic main universe'
6. sudo apt-get update
For instance, you're missing this package, you may install it
7. sudo apt-get install libwebkitgtk-1.0-0
If error appears after such install
8. sudo apt-get -f install
then
9. sudo dpkg -i modelio-open-source_4.1.0_ubuntu_amd64.deb
If there is no error, hooray, you've successfully installed Modelio.

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago #6282 by zeelog
i have got similar problems installing in xubuntu 16.04 .

i have repair the dependance libwebkitgtk-1.0 after installation with the command :

sudo apt-get -f install

Please Log in or Create an account to join the conversation.

Moderators: cde
Time to create page: 0.058 seconds
^ Back to Top