exclamation-circle Build Modelio 4 on Arch x86_64: A fatal error has been detected by the JRE

2 weeks 2 days ago - 2 weeks 2 days ago #5875 by aks
I am trying to build Modelio 4 on Arch, as it is not provided by default.
I downloaded the following source file : Modelio 4 Source Zip
I am following this guide : Get Modelio Sources
Configure Eclipse is done successfullly. There were errors about some "src" directories not existing, so I creating empty ones.
Compile is also done successfully with 0 errors and 6590 warnings.
Test The Build --> Launch an Eclipse Application creates a fatal error.
As shown in eclipse console :
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fb390f41430, pid=42964, tid=0x00007fb3d4227700
#
# JRE version: OpenJDK Runtime Environment (8.0_242-b08) (build 1.8.0_242-b08)
# Java VM: OpenJDK 64-Bit Server VM (25.242-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libglib-2.0.so.0+0x79430]  g_str_hash+0x0
#
# Core dump written. Default location: /home/adi/core or core.42964
#
# An error report file with more information is saved as:
# /home/adi/hs_err_pid42964.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

What to do now?
Please ask if more information is required.
Thank you!
Attachments:

Please Log in or Create an account to join the conversation.

1 week 5 days ago #5879 by ffe
Hello Aks,

Modelio needs the webkit library. Please, make sure it is installed on your system.

Best regards,

Please Log in or Create an account to join the conversation.

6 days 17 hours ago - 6 days 17 hours ago #5887 by aks
Thank you for your response!
Before starting the build process, I have checked for all dependencies.
I was getting many errors stating Plugin Execution not covered by lifecycle configuration. So, I went to
Window -> Preferences -> Maven -> Errors/Warnings -> Plugin Execution not covered by lifecycle configuration -> Warning
(i.e., changed selected "Warning" in place of "Error").
Then, I had some build path error on editors.richnote.libreoffice. So, I installed libreoffice-still-sdk. and edited the required jar paths to it (juh.jar, jurt.jar, ridl.jar, unoil.jar). Eclipse copied these jar files to the required path (.../modelio_sources/dev-platform/compilation-env/libreoffice3.6/).
Build is successful with 7948 warnings

I have the following softwares with webkit name already installed : qt5-webkit and webkit2gtk. [Note: I am not allowed by this forum to add many links. So, all of the links are in a txt file inside the zip attached.]
I tried running eclipse with and without
export SWT_GTK3=0
but to no avail. Then I thought, Modelio might using the old, legacy webkit. So, I installed the following package webkitgtk.[Again, link in txt file.]
After doing this, I am able to Launch an Eclipse Application. Modelio 4.0 launches (1 problem was displayed as shown in screenshots) but isn't quite usable. See the screenshots attached.[In the zip file as I wasn't allowed to post many images.]
These are few of the last lines shown at eclipse console :
The code is in eclipse_console.txt in zip
Nevertheless, I tried running
mvn package
and it fails with a long list of error.
The code is in maven.txt file in zip.
I'm in dilemma. I have been trying to build modelio for usage since 2 weeks. Please suggest how to debug these problems.
Also, if you could prove a .tar.gz package for installation, I won't have to trouble with this complex build process. However, if you could guide me to successfully build your software, it is more than welcomed.
Thanks!

File Attachment:

File Name: files_img.zip
File Size:58 KB
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: oslcde
Time to create page: 0.036 seconds
^ Back to Top