file .modelio/3.8/.eclipse/configuration.x86_64.os/1552049214616.log on Mac

7 months 1 week ago #5576 by pan

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago #5591 by Belly
I have the same problem as yours!:( Do you solve it?

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago #5592 by pan
Did you try the provided solution?

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago #5593 by Belly
I opened the Modelio once.But when I closed it and tried again, it failed.
The error was "see the log file /Users/.../.modelio/3.8/.eclipse/configuration.x86_64.os/1553608558408.log"
Then I find the log file and see it.
"!SESSION Tue Mar 26 21:55:58 CST 2019
!ENTRY org.eclipse.equinox.launcher 4 0 2019-03-26 21:55:58.410
!MESSAGE Could not find extension: reference:file:org.eclipse.osgi.compatibility.state_1.1.0.v20170516-1513.jar
!ENTRY org.eclipse.equinox.launcher 4 0 2019-03-26 21:55:58.414
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:650)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
"
I also tried what you recommended.I find the modelio.ini and add.
" -startup
../Eclipse/plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
--launcher.library
../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.551.v20171108-1834
-clearPersistedState
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.8
--add-modules=ALL-SYSTEM
-Xms512m
-Dpython.console.encoding=UTF-8
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
"
But it fails.I also read others' error and solution.just about java 8 or the modelio.ini.I have all tried the provided solution.
my macOs High Sierra 10.13.6
java version "1.8.0_181"
Java(TM) SE Runtime Environment (build 1.8.0_181-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.181-b13, mixed mode)
I have stuck with the problem for a week.Can anyone help´╝čThanks.
(My English is not well.Sorry.)

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago #5594 by Belly
Yes,I tried it.But it doesn't work

Please Log in or Create an account to join the conversation.

6 months 3 weeks ago #5595 by pan
Can you remove the line "--add-modules=ALL-SYSTEM" and try again?

Please Log in or Create an account to join the conversation.

Moderators: oslcde
Time to create page: 0.044 seconds
^ Back to Top