file Modelio Archimate Plugin for Mac OS

2 years 1 month ago #4400 by ffe
Hi Strejog99,

To install the Modelio ArchiMate plugin :

1. Download the ArchiMate plugin for Mac OS X (the archive file name is : modelio-archimate-3.6.0.tar.gz)
2. Uncompress the archive (double-click on it). The "dropins" directory should appear.
3. Close all of the Modelio Open Source application instances
4. Go to the Modelio 3.6 application.
5. Open the contextual menu on Modelio 3.6 and run the "Show Package Contents" command.


6. Now browse the Modelio 3.6 application contents and expand the Contents and Contents/Eclipse directories in order to obtain this:


7. Copy the "dropins" directory (from step 2) into the "Contents/Eclipse" directory of the Modelio 3.6 application. After the copy you should obtain:


8. Modelio 3.6 Open Source can now be restarted

Best regards,
Attachments:

Please Log in or Create an account to join the conversation.

2 years 1 month ago #4401 by strejog99
Thanks for your help.

I did it as instructed, but... I got an error message.

The log file includes:

SESSION Tue Feb 28 08:59:14 CST 2017
!ENTRY org.eclipse.equinox.launcher 4 0 2017-02-28 08:59:14.409
!MESSAGE Could not find extension: reference:file:org.eclipse.osgi.compatibility.state_1.0.100.v20150402-1551.jar
!ENTRY org.eclipse.equinox.launcher 4 0 2017-02-28 08:59:14.415
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:666)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:608)
at org.eclipse.equinox.launcher.Main.run(Main.java:1515)

Please Log in or Create an account to join the conversation.

2 years 1 month ago #4402 by ffe
Hi Strejog99,

Can you please check the following?

* With Finder, can you go to '~/.modelio/3.6/.eclipse' folder and remove all its content.
After this operation, does Modelio Work?

* Does Modelio work if you remove the "dropins" directory?

Best regards,

Please Log in or Create an account to join the conversation.

2 years 1 month ago #4403 by strejog99
Done!!

Thanks a lot!!

Sam.

Please Log in or Create an account to join the conversation.

2 years 1 month ago #4404 by ffe
Is it the removal the .eclipse directory content that resolve your problem ?

Please Log in or Create an account to join the conversation.

2 years 1 month ago #4405 by strejog99
Yes, I removed the .eclipse directory and tried again. It worked, including the archimate plugin.

Please Log in or Create an account to join the conversation.

Moderators: oslcde
Time to create page: 0.329 seconds
^ Back to Top