exclamation-circle not able to install on ubuntu 14.04 64b

4 years 3 months ago #3288 by pedro.jvrc.costa
Hi,

I'm trying to install modelio 3.3.1 on a Ubuntu 14.04 64b.

It is failing both at file manager and CLI. (I installed the same version on a WInP7 and it's fine so far.

A few first lines (there are too many very similar) from the .log are:
"
!SESSION 2015-03-26 17:45:46.967
eclipse.buildId=unknown
java.version=1.7.0_75
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments: -clearPersistedState
Command-line arguments: -os linux -ws gtk -arch x86_64 -clearPersistedState

!ENTRY org.modelio.admtool 4 0 2015-03-26 17:45:50.021
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.modelio.admtool [196]
Unresolved requirement: Require-Bundle: org.modelio.core.project
-> Bundle-SymbolicName: org.modelio.core.project; bundle-version="3.3.1.201502191117"
org.modelio.core.project [214]
Unresolved requirement: Require-Bundle: org.modelio.core.store.exml
-> Bundle-SymbolicName: org.modelio.core.store.exml; bundle-version="3.3.1.201502191116"
org.modelio.core.store.exml [217]
Unresolved requirement: Require-Bundle: org.modelio.core.kernel
-> Bundle-SymbolicName: org.modelio.core.kernel; bundle-version="3.3.1.201502191116"
org.modelio.core.kernel [213]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.modelio.api 4 0 2015-03-26 17:45:50.024
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.modelio.api [197]
Unresolved requirement: Require-Bundle: org.modelio.core.kernel
-> Bundle-SymbolicName: org.modelio.core.kernel; bundle-version="3.3.1.201502191116"
org.modelio.core.kernel [213]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"
...
"

Can someone help here, please?

Thanks in advance.

Pedro

Please Log in or Create an account to join the conversation.

4 years 3 months ago #3289 by pan
Hi pedro,

It seems that you are using JDK 7. Modelio 3.3.1 requires the JDK 8.

Hope this helps,
BR
The following user(s) said Thank You: pedro.jvrc.costa

Please Log in or Create an account to join the conversation.

4 years 3 months ago #3312 by Buster-Foxx
Yes, just install Java 8 and Modelio should run. This is true for both Ubuntu 12.04 and 14.04. If you have several versions of java installed (as most of us will), remember to set Java 8 as your default version. You can do this by entering the following in your command prompt:

sudo update-alternatives --config java

To change the default Java version: select the number that corresponds to the version you want to use.

Please Log in or Create an account to join the conversation.

Moderators: oslcde
Time to create page: 0.038 seconds
^ Back to Top