file Getting error message after installation on Mac OS X 10.10

3 years 9 months ago #3727 by jaracic
Hi,
I tried to install Modelio 3.3 on my OS X 10.11.1 and it does not works... java -version indicates I'm in java 7.

Is it possible to make modelio 3.3 running with an "embedded" java 8 ? (I need to keep java 7 on my machine by default for the moment).

I'm not a java specialist but I think it is possible to do such thing.

Does someone has an experience with that ?
Thanks.
Joseph.

Please Log in or Create an account to join the conversation.

3 years 9 months ago #3730 by pan
Hi,

You can install the JDK8 so you will have the 2 versions on your system.
Edit your ~/.bash_profile file and add these lines:
export JAVA_HOME=$(/usr/libexec/java_home -v 1.7)
setjdk() {
  export JAVA_HOME=$(/usr/libexec/java_home -v $1)
}
This will set the Java 7 as default version for Java.
Then if you need to set the Java 8 just type "setjdk 1.8" on the shell.

Does it help you?

Please Log in or Create an account to join the conversation.

3 years 9 months ago #3732 by jaracic
Hi pan,

Yes it helps. I'll try that.

Even if I'm not a developper at all, I don't understand why modelio 3.3 needs JDK (instead of JRE, and why it is not bundled into modelio package).
Is it the same issue for the "commercial" distribution ? because I want to install modelio 3.3 community edition for new tests before deciding to to buy the "System Architect Solution"+Team collaboration package in 2016.

Please Log in or Create an account to join the conversation.

3 years 9 months ago #3733 by pan
It is a limitation due to the MacOS X platform. We do not have the same constraints on Linux or Windows platforms...
You will have the same constraint on the commercial distribution.

We are aware of this limitation. We will work on finding a better solution for the macos x version of Modelio.
The following user(s) said Thank You: jaracic

Please Log in or Create an account to join the conversation.

3 years 4 months ago #3923 by joonsikjang@gmail.com
I have same problem.

I have attached my log file.
Attachments:

Please Log in or Create an account to join the conversation.

3 years 4 months ago - 3 years 4 months ago #3926 by ebr
It seems that you do not have a JDK 8 on your computer...

Please Log in or Create an account to join the conversation.

Moderators: oslcde
Time to create page: 0.044 seconds
^ Back to Top