file Can't locate companion shared library

4 years 5 months ago #3218 by hstoellinger
Looking at modelio.log...

!ENTRY org.modelio.diagram.editor.deployment 2 0 2015-02-26 13:33:15.919
!MESSAGE Could not resolve module: org.modelio.diagram.editor.deployment [229]
Unresolved requirement: Require-Bundle: org.modelio.diagram.editor
-> Bundle-SymbolicName: org.modelio.diagram.editor; bundle-version="3.3.1.201502191123"; singleton:="true"
org.modelio.diagram.editor [224]
Unresolved requirement: Require-Bundle: org.modelio.core.ui
-> Bundle-SymbolicName: org.modelio.core.ui; bundle-version="3.3.1.201502191121"
org.modelio.core.ui [218]
Unresolved requirement: Require-Bundle: org.modelio.metamodel.emfapi
-> Bundle-SymbolicName: org.modelio.metamodel.emfapi; bundle-version="3.3.1.201502191117"
org.modelio.metamodel.emfapi [257]
Unresolved requirement: Require-Bundle: org.modelio.core.kernel
-> Bundle-SymbolicName: org.modelio.core.kernel; bundle-version="3.3.1.201502191116"
org.modelio.core.kernel [213]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"


!ENTRY org.modelio.module.commands 2 0 2015-02-26 13:33:15.920
!MESSAGE Could not resolve module: org.modelio.module.commands [264]
Unresolved requirement: Require-Bundle: org.modelio.api
-> Bundle-SymbolicName: org.modelio.api; bundle-version="3.3.1.201502191121"; singleton:="true"
org.modelio.api [197]
Unresolved requirement: Require-Bundle: org.modelio.core.kernel
-> Bundle-SymbolicName: org.modelio.core.kernel; bundle-version="3.3.1.201502191116"
org.modelio.core.kernel [213]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"


!ENTRY org.eclipse.osgi 4 0 2015-02-26 13:33:15.920
!MESSAGE Application error
!STACK 1
org.eclipse.core.runtime.AssertionFailedException: null argument:applicationXMI argument missing
at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:85)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.loadApplicationModel(E4Application.java:373)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:260)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:146)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)

Please Log in or Create an account to join the conversation.

4 years 5 months ago #3220 by cde
Hi,

According to your log file, JRE 1.8 is missing on your system.
Since version 3, Modelio requires a JRE 1.8 to run.

Best regards,
cde

Please Log in or Create an account to join the conversation.

4 years 5 months ago #3222 by hstoellinger
Hello and many thanks! It now starts o.k....
:up

Please Log in or Create an account to join the conversation.

4 years 5 months ago #3223 by hstoellinger
One shouldn't laugh TOO soon! Now, when I want to look into "Preferences", modelio just crashes with the following message:
./modelio: Zeile 16: 10071 Abgebrochen "${MODELIO_PATH}/m-bin" --launcher.ini "${MODELIO_PATH}/modelio.ini" $*
Any idea? :(

Please Log in or Create an account to join the conversation.

4 years 5 months ago #3224 by hstoellinger
Well, maybe there is more info in the enclosed file...

Please Log in or Create an account to join the conversation.

4 years 5 months ago #3225 by hstoellinger
o.k., o.k., I'll try again... :evil:
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: oslcde
Time to create page: 0.040 seconds
^ Back to Top