lock [Solved] Ubuntu 64 bit 10.04 - modelio can't load 'libmodelio.so'

7 years 4 months ago #302 by porchrat
Do I just create a new export for MOZILLA_FIVE_HOME in the modelio.sh script?

I found what looks to be my xulrunner directory under /usr/lib/xulrunner-1.9.2.24.

Then I added this line to the modelio.sh script:
export MOZILLA_FIVE_HOME="/usr/lib/xulrunner-1.9.2.24"
but it had no effect. I still get the same error echoed to the terminal as before.

Note though that there is no mention of MOZILLA_FIVE_HOME in this script before I added it.
The topic has been locked.
7 years 4 months ago #303 by ffe
Don't use the xulrunner installed by Ubuntu 10.04 64-bit. This xulrunner is a 64-bit version and Modelio must use a xulrunner 32-bit.

I recommend you download the archive 32-bit from mozilla:
ftp://ftp.mozilla.org/pub/mozilla.org/xu...S.linux-i686.tar.bz2

After uncompressing this archive, don't forget to run the following command in the xulrunner directory:
./xulrunner --register-user

The variable MOZILLA_FIVE_HOME must be set with this xulrunner path. Modelio must know this variable environment, so it is a good idea to edit the modelio.sh and to set the MOZILLA_FIVE_HOME.
The topic has been locked.
7 years 4 months ago #304 by porchrat
This all makes sense. MOZILLA_FIVE_HOME must explicitly be set to that xulrunner path or else it is going to default to the one I have installed?

I will grab that archive and do as you have suggested. I wish the dude from that other thread had posted what happened after he got everything sorted and how he went about it. Oh well, hopefully this thread will serve as a guide to those like me that need step by step instruction :P.

I'm also currently downloading the Windows version as a fallback if I can't get this version to run on Ubuntu. I certainly hope I get it running though.
The topic has been locked.
7 years 4 months ago - 7 years 4 months ago #305 by porchrat
YES!!! It starts!! I now see the welcome page with "getting started" and a few other options.

You sir are a genius! :)

Thank you so very much for all your help in getting Modelio working.

EDIT: one more thing, how do I mark this thread solved?
The topic has been locked.
7 years 4 months ago #306 by chm
Congratulations porchrat. B)

Don't worry about the thread, a moderator will mark it solved one day or another!
The topic has been locked.
7 years 4 months ago - 7 years 4 months ago #309 by osl
Marked as solved.
Thread locked.

Go pro
The topic has been locked.
Moderators: oslcde
Time to create page: 0.042 seconds
^ Back to Top