question-circle Modelio 2.2 not working on Linux x86_64

6 years 6 months ago - 6 years 6 months ago #1177 by cristo
Hi all,

I am using Arch Linux x86_64, and tried to setup Modelio 2.2 for Linux 64bit. After installing all the dependencies mentioned in the installation instructions , it did not work.

I noticed that the issue was to set up the MOZILLA_FIVE_HOME env variable, so I set it up by modifying modelio.sh script (I got a little bit confused because in that script, MOZILLA_FIVE_HOME is unset, so I replaced that line). Now, when Modelio starts, I got a jvm crash. I am attaching the hs_err file in this post.

I found some posts in this forum saying that Modelio won't work unless xulrunner is installed. Moreover, they are saying that you need to install xulrunner for 32 bits, and install 32 bit compatibility libraries for Modelio to work on x86_64, ┬┐is this true?. I would not like on install this libraries, as I just want a pure 64 bit installation.

I tried to compile Modelio by myself to avoid the need to install 32 bit libraries, but I can't find the source code in the site (neither in the sourceforge one).

Thanks a lot for any help you could provide.

---

File Attachment:

File Name: hs_err_pid7760.txt
File Size:80 KB
Attachments:

Please Log in or Create an account to join the conversation.

6 years 6 months ago #1196 by ffe
Hi Cristo,

Modelio version 64-bit works and it has been tested on Ubuntu 12.04 64-bit but not on Arch Linux.
Modelio uses either Webkit librairy or Xulrunner (version 1.9.x) and we recommend to use the Webkit library. In your case, please check the Webkit librairy is installed and don't remove the "unset MOZILLA_FIVE_HOME" in order to use the Webkit librairy instead of the Xulrunner.

You will find the Modelio sources on our forge:
forge.modelio.org/projects/modelio

Please, if you have installed the webkit library, can you give us the version ?

Please Log in or Create an account to join the conversation.

6 years 6 months ago - 6 years 6 months ago #1200 by cristo
Hi ffe,

Thanks for you answering. I am finally able to use Modelio now. The issue has to do with a known bug on SWT that prevents the Web Browser widget to find WebKit libraries. More info can be found here and here .

Thanks again for your quick answer.

Please Log in or Create an account to join the conversation.

Moderators: oslcde
Time to create page: 0.041 seconds
^ Back to Top