file Hello World / Maven Project Tutorial

1 year 10 months ago #6007 by ebr
Hi,

What are the verions of your Modelio? JDK? OS?

Thanks,
EBR

Please Log in or Create an account to join the conversation.

1 year 6 months ago #6286 by joset
Hi, i have the same problem with version 5.0.0.0

:-(

Please Log in or Create an account to join the conversation.

1 year 5 months ago - 1 year 5 months ago #6308 by cma
Hello,

From the error message I guess you are using JDK 11 .

'modelio-maven-plugin' uses the JAXB library, which has been removed from JDK since version 11.

Modelio is delevopped with Java 8 and is not compatible with Java 11.
The only solution for the moment is to use JDK 8 to make a Modelio module.

Regards,

CMA
The following user(s) said Thank You: mjoy99

Please Log in or Create an account to join the conversation.

1 year 2 months ago #6376 by mjoy99
I will have to check this out. It has been a steep learning curve recently with Maven, different JDKs and decency libraries. Forgot all about this. Will need to go back and look at it again.

Please Log in or Create an account to join the conversation.

5 months 2 weeks ago #6493 by bit
Hi, I had the same problem. I solved it by adding some dependencies inside the plugin declaration of the pom.xml file.

<plugin>
<groupId>org.modelio</groupId>
<artifactId>modelio-maven-plugin</artifactId>
<version>5.1.0.00</version>
<executions>
<execution>
<id>ModuleValidation</id>
<phase>validate</phase>
<goals>
<goal>module-validation</goal>
</goals>
</execution>
<execution>
<id>ResourceManagement</id>
<phase>generate-resources</phase>
<goals>
<goal>module-configuration</goal>
</goals>
</execution>
</executions>
<configuration>
<moduleFile>${project.basedir}/src/main/conf/module.xml</moduleFile>
</configuration>
<dependencies>
<dependency>
<groupId>javax.xml.bind</groupId>
<artifactId>jaxb-api</artifactId>
<version>2.3.0</version>
</dependency>
<dependency>
<groupId>com.sun.xml.bind</groupId>
<artifactId>jaxb-impl</artifactId>
<version>3.0.2</version>
</dependency>
<dependency>
<groupId>org.glassfish.jaxb</groupId>
<artifactId>jaxb-runtime</artifactId>
<version>2.3.1</version>
</dependency>
<dependency>
<groupId>javax.activation</groupId>
<artifactId>activation</artifactId>
<version>1.1.1</version>
</dependency>
</dependencies>
</plugin>

Please Log in or Create an account to join the conversation.

3 months 2 weeks ago #6506 by 2k4j
I have tried downloading the archetypes without any success in the Hello World tutorial. I tried the latest version and the version mentioned in the tutorial. How can I manually load the archetype?

Please Log in or Create an account to join the conversation.

Moderators: tma
Time to create page: 0.044 seconds
^ Back to Top