file Webkit internal error Modelio 4.0

3 weeks 6 days ago #5752 by littlekitty
Hello,

I've installed Modelio 4.0 on ubuntu mate 19.10 and whenever I try to edit an element of a diagram, a window appears with the error message :
org.eclipse.swt.SWTException: Failed to execute runnable (org.eclipse.swt.SWTError: No more handles because no underlying browser available.
   Please ensure Webkit with its Gtk 3.x bindings installed. Webkit2 API level preferred.
)
Failed to execute runnable (org.eclipse.swt.SWTError: No more handles because no underlying browser available.
   Please ensure Webkit with its Gtk 3.x bindings installed. Webkit2 API level preferred.
)

I tried installing several webkit packages in ubuntu repository but I can't resolve this issue. Did I miss something ?

Please Log in or Create an account to join the conversation.

3 weeks 3 days ago #5754 by pan
Hello littlekitty,

Open a shell and initialize the following environment variable SWT_GTK2 to 1.
Then run the following command: modelio-open-source4.0.
Open your project and try to edit an element again.

Let us know if it helps.

BR

Please Log in or Create an account to join the conversation.

3 weeks 3 days ago #5755 by Jascha Knack
Hello,

i had the same problem and was able to solve it by changing
SWT_WEBKIT2=0 to 1
in the
/etc/modelio-open-source4.0/modelio.config file.
The following user(s) said Thank You: pan

Please Log in or Create an account to join the conversation.

3 weeks 3 days ago #5756 by pan

Open a shell and initialize the following environment variable SWT_GTK2 to 1

My mistake, it is SWT_WEBKIT2 thanks to Jascha Knack for the answer :up

Please Log in or Create an account to join the conversation.

Moderators: tmaebr
Time to create page: 0.034 seconds
^ Back to Top