Submit a problem

In order to provide you the best help possible to analyze and debug your problems please provide us some information about your environment.
When you submit a problem, please indicate:
- The Version, Build Id, Core Id, System and Architecture (You can get these information in the Help/About menu entry)
- The Modelio Edition (Modelio Open Source or Modelio by Modeliosoft)
- Your Operating System

file Migration freezes

3 weeks 1 day ago #4617 by waldoor
Installed a new version of Modelio (Version 3.6.01 Build: 201703061558 System: win32 (6.1) Architecture: x86_64) and tried to open an project created witv earlier version (<3.4).
The migration freezes while saving repository (5/9) and is producing an internal error:
java.io.IOException: The 'PredefinedTypes 3.2.00' fragment's 'Standard v1.0.9022' metamodel is outdated compared to the current 'Standard v2.0.00' version.
The 'PredefinedTypes 3.2.00' fragment's 'Standard v1.0.9022' metamodel is outdated compared to the current 'Standard v2.0.00' version.
How to solve this?

Please Log in or Create an account to join the conversation.

2 weeks 2 days ago - 2 weeks 2 days ago #4631 by osl
Hi,

Don't you have another message window in the background that requires clicking too?
When migrating a project, Modelio can migrate several model fragments, and confirmation boxes may overlap one another.

If you don't see another window blocking the process, you may want to increase the ammount of memory allocated to Modelio by adding the following arguments to its start command / shortcut:
-vmargs -Xms1024m -Xmx4096m
(adjust to your machine's config)

BR

Go pro

Please Log in or Create an account to join the conversation.

2 weeks 1 day ago #4633 by waldoor
Adding the arguments did not work.

I see a warning:
The 'project' fragment's 'Standard v1.0.9022' metamodel is outdated compared to the current 'Standard v2.0.00' version.
and a separate one:
java.io.IOException: The 'PredefinedTypes 3.2.00' fragment's 'Standard v1.0.9022' metamodel is outdated compared to the current 'Standard v2.0.00' version.

Is here anything I can/need to do here?

Please Log in or Create an account to join the conversation.

1 week 4 days ago #4634 by pan
Hi Waldoor,

Did you update the Modeler Module?
Go to Configuration/Modules... and check the compatibility status on the Modeler Module row.

BR

Please Log in or Create an account to join the conversation.

Moderators: tmaebr
Time to create page: 0.054 seconds
^ Back to Top