Submit a problem

In order to provide you the best help possible to analyze and debug your problems please provide us some information about your environment.
When you submit a problem, please indicate:
- The Version, Build Id, Core Id, System and Architecture (You can get these information in the Help/About menu entry)
- The Modelio Edition (Modelio Open Source or Modelio by Modeliosoft)
- Your Operating System

check [Solved] Internal Error while editing diagrams after update from v3.5 to v3.6.1

4 months 2 weeks ago - 1 month 3 weeks ago #4410 by Ralf.Ebert
Helle, after an update from Modelio v3.5 to Modelio v3.6.1 I'm not able to work with a diagram. I can open it but if I will change a diagram I get an internal error message which looks like:
Internal Error
Reason:
org.eclipse.e4.core.di.InhectionException: org.eclipse.e4.core.di.InjectionException: 
java.lang.NullPointerExceoption

After updating I've also updated the modules SysMLArchitect, ModelerModule and WebModelPublisher

My System is:
Microsoft Windows 7 Professional 64-Bit
6.1.7601 Service Pack 1 Build 7601
x64-based PC

Used version of Modelio:
Version 3.6.01
Build: 201703061558
System: win32 (6.1)
Architecture: x86_64

Java-Version (found in <Modelio v3.6>/jre
java version "1.8.0_102"
Java(TM) SE Runtime Environment (build 1.8.0_102-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.102-b14, mixed mode)


How Can I solve my problem?

Best Regards
Ralf Ebert

Please Log in or Create an account to join the conversation.

4 months 2 weeks ago - 4 months 2 weeks ago #4411 by osl
Hello Ralf,

Could you please post your Modelio log here?
Find it in c:\users\username\.modelio\3.6\

[edit] Also, if possible, you can export your project and send it to me via private message (use wetransfer or any equivalent for large archives).


Regards,

--
OSL

Go pro

Please Log in or Create an account to join the conversation.

4 months 1 week ago #4414 by Ralf.Ebert
Hi OSL

I think there is no need to send the project to you because I can reproduce the effect with new projects too:
- Create a non java project named test
- Add a sequence diagram to packet test
- Click in the diagram editor
- The internal error occurs

I've attached a screenshot with the message and the last log file

Regards
Ralf
Attachments:

Please Log in or Create an account to join the conversation.

4 months 1 week ago #4418 by osl
Hi Ralf,

I can't reproduce with the scenario.

Can you try the following:
  1. Close your project and leave Modelio
  2. Go to C:\users\username\.modelio\
  3. Delete the \3.6\ folder
  4. Start Modelio and try again

How does it help?

Best regards,

--
OSL

Go pro

Please Log in or Create an account to join the conversation.

4 months 1 week ago #4419 by osl
In case you still have the same error, can you change the log level to 'debug' and post the log here?
Go to 'Configuration > Preferences > Administration > Log level = Debug'

--
OSL

Go pro

Please Log in or Create an account to join the conversation.

4 months 1 week ago #4420 by Ralf.Ebert
Deleting the 3.6-folder hasn't solved the problem. After I've removed my complete workspace too I can edit diagrams now.
Funny --- after reactivating the old workspace it seems I can edit diagrams in my main project too.
Thank you for your suggestion

Regards
Ralf

Please Log in or Create an account to join the conversation.

Moderators: tmaebr
Time to create page: 0.071 seconds
^ Back to Top