file [SOLVED] IOException and metamodel outdated after upgrade to 3.6

9 months 4 weeks ago - 9 months 3 weeks ago #4362 by barmeier
Hi,

after upgrading to Modelio version 3.6 I get this when I open my old models.
java.io.IOException: The 'PredefinedTypes 3.2.00' fragment's 'Standard v1.0.9022' metamodel is outdated compared to the current 'Standard v2.0.00' version.
The 'PredefinedTypes 3.2.00' fragment's 'Standard v1.0.9022' metamodel is outdated compared to the current 'Standard v2.0.00' version.

How can I fix this ?

Ciao
Matze

Please Log in or Create an account to join the conversation.

9 months 3 weeks ago #4364 by barmeier
Hi,

solved the problem. It looks like the upgrade process has not added the correct Modeler plugin to the project. After setting the plugin manually via the Configuration menu everything seems to work.

I think this should be done during the upgrading process.

Ciao
Matze

Please Log in or Create an account to join the conversation.

3 months 4 weeks ago #4563 by consuelofranky
Please, can you explain how to set the plugin manually via the Configuration menu ?

Please Log in or Create an account to join the conversation.

3 months 4 weeks ago #4564 by barmeier
To fix the problem I opened the project and selected Configuration. I switched through the tabs and noticed that there were some marked as invalid. After pressing the Add Button I selected the modules marked as compatible.
Thats it.

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago #4566 by consuelofranky
Thank for your answer.
I followed your indications with sucess but before I removed all trace of Modelio 3.5

Please Log in or Create an account to join the conversation.

Moderators: tmaebr
Time to create page: 0.029 seconds
^ Back to Top