file [Solved] Stereotype and image

7 years 9 months ago #403 by michok34
Hi,

I've created a stereotype in my MDA localProfile, I set an image 16x16 that is added in the right top corner of my element (no problem with it) and I set a 48x48 (bmp or png). When I select "Image" in "representation mode" of Symbol tab but it displays "No Image" in my diagram.

Am I doing something wrong or did I miss a step in stereotype creation ?

thanks.

Please Log in or Create an account to join the conversation.

7 years 9 months ago #404 by barbe.rousse
Hi,

When you created your stereotype have specified an image for the Diagram image?

When you select your created stereotyped, what is the value of the Diagram image field visible in the Element tab?

Regards,

BR

Please Log in or Create an account to join the conversation.

7 years 9 months ago #405 by tma
You can see a video tutorial : MDA define model extensions on Modelio

Please Log in or Create an account to join the conversation.

7 years 9 months ago #407 by michok34
Hi,

@tma: thanks. So I didn't screw any step of creation.

@barbe.rousse: yes I did specify the field Diagram Image.
extended class for my stereotype is "Lifeline"
value in "Icon" is "LocalModule/res/bmp/smallimage.bmp"
value in "diagram Image" is "LocalModule/res/bmp/bigimage.bmp"

regards.

Please Log in or Create an account to join the conversation.

7 years 9 months ago #409 by barbe.rousse
Hi,

In fact actually it does not seem possible with Lifelines...

Regards,

BR

Please Log in or Create an account to join the conversation.

7 years 9 months ago #410 by michok34
I hope it'll possible someday.

Regards

Please Log in or Create an account to join the conversation.

Moderators: tmaebr
Time to create page: 0.048 seconds
^ Back to Top