question-circle Deployment Diagram problem

5 years 4 months ago - 5 years 4 months ago #3383 by mtkona
Hello,

I am creating a deployment diagram and I'm in trouble. I looked for a tutorial on the site, but have not found. Do you have any tutorial?

I need to create a deployment diagram that has node and artifacts and links between them, as the attached example.



In Modelio I created a node, but
I can not place the device within the node or the component.

Could you help me?

Thank you,

Marcelo
Attachments:

Please Log in or Create an account to join the conversation.

5 years 4 months ago - 5 years 4 months ago #3395 by ebr
Hi,

So you are able to create Nodes, the second step is the "link" between them which are Association as depicted below



The artifeact or component deployment can be done in two ways.
First you create a dependency from your artifact or component to the node and then stereotype it as deployment (cf. the screenshot below)



The second option also valid consist in creating an Instance inside your node set the artifact od the component as base of the instance.



Hoping it helps,

EBR
Attachments:

Please Log in or Create an account to join the conversation.

5 years 4 months ago #3398 by mtkona
Hi, thank you for reply.

I'm still having trouble in creating this diagram. I can not find the option to put in the "Component" diagram object (see Fig. 1).





Also, when creating the instance of the device, it is as the figure "deploymentdiagram.jpg".

Attachments:

Please Log in or Create an account to join the conversation.

5 years 4 months ago #3399 by ebr
You are right, Component creation command are not available on Deployment diagram.

So you have to create a Component into the model explorer thanks to the explorer command as depicted below or to another diagram



Then drag and frop the created component from the model explorer into your deployment diagram.

Hoping it helps,

EBR
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: tma
Time to create page: 0.794 seconds
^ Back to Top