file [Solved] problem for opening class diagram

8 years 11 months ago #193 by jce7135
Hi,

I have worked on a project with modelio for two weeks, created 5 class diagrams, and today, for no obvious reason, I cannot open 3 of them anymore. When I click on them in the GUI, nothing happens.
I had a look at the logs :
java.lang.ClassCastException: com.modeliosoft.modelio.api.model.ObClass cannot be cast to com.modeliosoft.modelio.api.model.uml.statik.IOperation
at com.modeliosoft.modelio.diagram.editor.statik.elements.operation.GmOperation.getRelatedIElement(GmOperation.java:215)
at com.modeliosoft.modelio.diagram.editor.statik.elements.operation.GmOperation.getRelatedIElement(GmOperation.java:1)
at com.modeliosoft.modelio.diagram.elements.common.abstractdiagram.GmAbstractDiagram$ModelChangeListener.refreshAllDiagram(GmAbstractDiagram.java:595)
at com.modeliosoft.modelio.diagram.elements.common.abstractdiagram.GmAbstractDiagram$ModelChangeListener$1.run(GmAbstractDiagram.java:553)
at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:179)
at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:150)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:4584)
at com.modeliosoft.modelio.diagram.elements.common.abstractdiagram.GmAbstractDiagram$ModelChangeListener.handleModelChange(GmAbstractDiagram.java:513)
at com.modeliosoft.modelio.core.internal.core.ModelImpl.fireModelChangeHandlers(ModelImpl.java:146)
at com.modeliosoft.modelio.core.internal.core.model.C2JModelChangeManager.handleModelChange(Unknown Source)
at com.modeliosoft.modelio.core.internal.core.NativeModelingSession._commitTransaction(Native Method)
at com.modeliosoft.modelio.core.internal.core.NativeModelingSession.commit(Unknown Source)
at com.modeliosoft.modelio.core.ModelingSession.commit(ModelingSession.java:166)
at com.modeliosoft.modelio.app.modules.listDlg.ModulesActivationDlg.okPressed(ModulesActivationDlg.java:311)
at org.eclipse.jface.dialogs.Dialog.buttonPressed(Dialog.java:472)
at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:624)

Strangely, the 2 other diagrams still work as before, I can open them.

Does anyone have a clue about what to do to get my diagrams back ?
Thanks !

Please Log in or Create an account to join the conversation.

8 years 11 months ago #199 by fpo
Hi,

We are currently investigating the problem.
We'll keep you informed as soon as possible if we find a way to get your diagrams back.

Please Log in or Create an account to join the conversation.

8 years 11 months ago - 8 years 11 months ago #219 by cde
Hi,

Your issue has been fixed in the new 2.0.2 patch.
To be able to open your diagrams again, you just have to update your current Modelio with the new version : Modelio 2.0.2, available for download on our store , and on the Modelio Community website if your are using the Open Source version.

Best regards,

Please Log in or Create an account to join the conversation.

Moderators: tma
Time to create page: 0.039 seconds
^ Back to Top