file MacOS Big Sur Upgrade Request - Use of Newer Eclipse and Embedded JVM

1 month 1 week ago #6293 by jimjohan
Based on GitHub discussion here: github.com/ModelioOpenSource/Modelio/issues/10 for use on MacOS Big Sur, it appears Modelio needs to be built on a newer release of Eclipse, say Eclipse 4.18. This may allow a later version of Java to be used (say, Java 11). It is also recommended to bundle a Java Runtime Environment JVM within the Mac version of the app. so that it runs out of the box without external dependencies. I believe this would then act more like the Windows and Linux installers.

Is this possible or planned in the near term? What would be the possible time frame for this to be fixed? I am teaching a class using Modelio it it is now broken for Mac users who recently upgraded.

Thank you

Please Log in or Create an account to join the conversation.

Moderators: cde
Time to create page: 0.033 seconds
^ Back to Top