check [Solved] ClassDiagram from XMI

1 year 11 months ago - 1 year 10 months ago #4534 by tfrueh
Hi everyone,

When I create a new project and perform an XMI import, I just get the elements (i.e. classes), including their attributes, associations etc. in the project tree. When I create an empty class diagram and try to add the classes using drag and drop, Modelio displays the classes only; without attributes or associations between them.

I'm wondering if there is an option to create a ClassDiagram from an XMI file? Obviously, the position of each element is not included in the XMI file. However, I'm fine with arranging them manually.

BTW: My Modelio version is 3.6.01 on Windows 7x64.

Thanks for any comment,
Thomas

Please Log in or Create an account to join the conversation.

1 year 11 months ago #4535 by pan
Hi tfrueh,

To show the attributes and methods of a Class, select the Class then go to the Properties view and on the Symbol tab then change the Show property for the Attributes and the Operations.
In a more general way, you can change the default properties for diagram styles (More information : forge.modelio.org/projects/modelio3-user...tings_diagram_styles ).

Hope this helps.
The following user(s) said Thank You: tfrueh

Please Log in or Create an account to join the conversation.

1 year 10 months ago #4536 by tfrueh
Hi pan,

Thank you for your reply - it got me almost there :). Attributes and methods are shown now, but associations between classes are not.

I added two screenshots to make this more clear. In project 1 I created two classes (person and house) and an association between them. After exporting this as XMI, I imported it in a new project 2, created a new Class Diagram and used drag and drop to add the two classes. However, no association appears between them, despite it is present in the XMI file.

I checked the settings under Configuration-->Diagram styles...->Class Association, but there is no option called "Show" as for example for Class-Attributes.

Is there another option for this?

Best regards,
Thomas


Attachments:

Please Log in or Create an account to join the conversation.

1 year 10 months ago #4537 by pan
Actually there is no option to unmask links automatically in the diagrams.

You can right-click on one of these classes and select the Unmask/Structuring Links commmand.

Hope this helps,
BR
The following user(s) said Thank You: tfrueh

Please Log in or Create an account to join the conversation.

1 year 10 months ago #4538 by tfrueh
Yes! That's exaclty what I tried to achieve.

Thanks a lot!

Please Log in or Create an account to join the conversation.

Moderators: cdeebr
Time to create page: 0.223 seconds
^ Back to Top