question-circle [Solved] TOGAF diagrams blocked when using SVN Team module

10 years 10 months ago - 10 years 10 months ago #48 by David
Hello,

I am currently evaluating the Modeliosoft Ultimate Solution Trial Version (Version 2.0.00.8006) together with the TOGAF Architect (tried Versions 2.0.10.8006 and 2.0.11.8006) and the SVN Teamwork manager for my studies at my university.
As I have no maintenance contract and the TOGAF Architect is developed by the community, I post my question here - I hope it's okay :)

I have now encountered a strange behavior during my evaluation:
When creating a project with TOGAF support and some corresponding diagrams (e.g. organization decomposition diagrams) and then adding the project to an SVN repository (by connecting to it). After that, none of the TOGAF diagrams can not be edited in any way any longer. E.g. it is not possible to place new elements on it or to move existings ones in the visual modeler.
No new TOGAF diagrams (except for matrix diagram) can be created any more. Most toolbar items are grayed out in TOGAF diagrams.
When e.g. trying to change colors in a TOGAF diagram via the property editors the following message appears:
>> \"An error has occurred. See error log for more details.
\'TOGAF::Diagrams::Organization Role diagram\' Static diagram cannot be modified.\" <<
The "default" UML diagrams, like class diagrams and so on, continue to work as expected.

Steps to reproduce:
- Create new project with TOGAF MDA (version 2.0.10.8006 or 2.0.11.8006) and SVN Team MDA
- Create arbitrary TOGAF diagram (e.g. an "organization decomposition diagram" for the business architecture)
- Connect to a SVN repository so that the project is under version control
- Try to edit the TOGAF diagram, e.g. try to change the background-color of the surface

Is this behavior a bug or did I just miss a configuration option or something alike?

Best wishes,
David

Please Log in or Create an account to join the conversation.

10 years 10 months ago - 10 years 10 months ago #49 by invader
Hi,

Did you get the SVN lock on those diagrams?
(Right-click on package / SVN Teamwork Manager / Get lock)

Please Log in or Create an account to join the conversation.

10 years 10 months ago #50 by David
Hey,

Thanks for the hint. I used "get lock"-command at the topmost/root element in the "UML" treeview that had the project name and the TOGAF symbol along with the "Is recursive" option. I thought that this would lock all elements, including the diagrams, in the project.

But now I took a closer look and saw that that only the specific TOGAF elements, like actors, roles, organisational units and so on were locked - but NOT the diagrams, which were also part of the project's tree-structure! When locking the diagrams manually, everything seems to work as expected.

So, this was a mistake from my side then, thank you again for your help! :)
Anyway I think the behavior could be outlined clearer in this case. Especially the "Is recursive" may lead to the expectation that everything below the selected tree-element is locked... Or at least more meaningful message could maybe shown when attempting to edit the model.

Best wishes
David

Please Log in or Create an account to join the conversation.

10 years 10 months ago - 10 years 10 months ago #51 by cde
Hi David!

The confusion comes from the fact that in the 'Model' explorer, only a 'reference' to the diagram appears, the "real" diagram appears in the 'Diagrams' explorer.
To get a lock (or commit or add to version) on a diagram you must do it from the Diagram explorer, where the diagram is "physically" present.
The SVN commands launched in the 'Model' explorer will not affect the reference to the diagrams, even if they are recursive.
For example, if you create a Class diagram CD1 with a package P1 as context, the CD1 diagram will appear in the 'Diagrams' explorer, and only a reference to CD1 will appear under P1 in the 'Model' explorer.
If you launch a recursive 'Commit' on P1, the reference to CD1 and the actual CD1 diagram will not be affected. To commit CD1 you will have to launch the command on the CD1 diagram in the 'Diagrams' explorer, or directly on the CD1 reference in the 'Model' explorer.

However there is a minor issue, as the lock state (green/red triangle or blue square) of the diagram (in the Diagrams explorer) should also appear on its reference in the Model explorer... This should be fixed in a next version...
The following user(s) said Thank You: ffe

Please Log in or Create an account to join the conversation.

Moderators: tmaaabcde
Time to create page: 0.038 seconds
^ Back to Top