file Shadow box in class diagram

1 year 3 months ago - 1 year 3 months ago #5602 by henryoktober
I have no idea why these shadow boxes are shown when I open the diagram. After I delete one of them the system says: "The operation has been rolled back. The model is safe."



Attachments:

Please Log in or Create an account to join the conversation.

1 year 3 months ago #5607 by pan
It seems that the AssociationEnd has been deleted from the model while the diagram was closed but it is strange because the Association should have been also deleted.
How did you delete the AssociationEnd?
The shadow box is normal. It is here to say that there was something here which have been deleted outside the diagram. But it is not normal that you cannot remove it.

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago #5713 by herr_spock
Dear all,


I have the same effect for a simple two class test model,
where one association end has been set to non-navigable
(see attachments).

When a model with a non-navigable end is loaded, obviously
the internal data is not correctly reconstructed. On the
one hand the diagram then shows the association name "gehört
zu", on the other hand its properties show a name of
"<null>".

Also it is not possible to set the end to "navigable" again.
To temporarily recover one has to delete the association and
create it again, which is annoying and, of course, not persistent.


Best regards,

Herr Spock
Attachments:

Please Log in or Create an account to join the conversation.

10 months 2 weeks ago #5714 by pan
Dear herr_spock,

We reproduced it. The development team will work on it.

Best regards
The following user(s) said Thank You: herr_spock

Please Log in or Create an account to join the conversation.

1 month 2 days ago #5922 by herr_spock
Hello pan,

thanks for your effort!

I am working with build 202001292132 and I still have problems with navigability.

Unfortunately now even the offending association cannot be deleted manually (and recreated) because the model shield says something like
"XXX has no other association end, action rolled back"
Of course, it has an end; but due to the non-navigability it now belongs to the association...

Any ideas on a workaround?

Best regards,

Herr Spock

Please Log in or Create an account to join the conversation.

Moderators: tmaaabcde
Time to create page: 0.275 seconds
^ Back to Top