file Shadow box in class diagram

4 months 3 weeks ago - 4 months 3 weeks ago #5602 by henryoktober
I have no idea why these shadow boxes are shown when I open the diagram. After I delete one of them the system says: "The operation has been rolled back. The model is safe."



Attachments:

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago #5607 by pan
It seems that the AssociationEnd has been deleted from the model while the diagram was closed but it is strange because the Association should have been also deleted.
How did you delete the AssociationEnd?
The shadow box is normal. It is here to say that there was something here which have been deleted outside the diagram. But it is not normal that you cannot remove it.

Please Log in or Create an account to join the conversation.

9 hours 22 minutes ago #5713 by herr_spock
Dear all,


I have the same effect for a simple two class test model,
where one association end has been set to non-navigable
(see attachments).

When a model with a non-navigable end is loaded, obviously
the internal data is not correctly reconstructed. On the
one hand the diagram then shows the association name "gehört
zu", on the other hand its properties show a name of
"<null>".

Also it is not possible to set the end to "navigable" again.
To temporarily recover one has to delete the association and
create it again, which is annoying and, of course, not persistent.


Best regards,

Herr Spock
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: tmaaabcdeebr
Time to create page: 0.270 seconds
^ Back to Top