check [Solved] Issues with Sequence Diagram

2 months 3 weeks ago - 2 months 2 days ago #5278 by alo
Hello,

I have an issue when i try to edit my sequence diagram... When i try any type of action like draging, adding, deleting, nothing happens. Sometimes, a green rectangle just appears, and everything is blocked...

Version 3.7.01
Build: 201803142330
System: win32 (10.0)
Architecture: x86_64

I can't share my project sorry, but here is my log file.

File Attachment:

File Name: Modelio.log
File Size:21 KB


I hope someone will be able to help me, thank you.
Attachments:

Please Log in or Create an account to join the conversation.

2 months 1 week ago #5282 by pan
Dear alo,

Do you encounter this behavior each time you are working with sequence diagrams? Can you show us a screenshot of a diagram encountering this kind of problem? Do you have a reproducible scenario?

Please Log in or Create an account to join the conversation.

2 months 1 week ago #5296 by alo
Hi pan,

Thank you for your reply.

Do you encounter this behavior each time you are working with sequence diagrams?

No, it's the only time i had this behavior, i did some sequence diagrams and had no worries with them.

Can you show us a screenshot of a diagram encountering this kind of problem?

I can show you this :

Before the behavior, i just tried to put an asynchronus message:


After that, the green rectangle just appears and nothing else is possible:

Do you have a reproducible scenario?

Unfortunately not, my diagram is "blocked", any kind of action seems to produce this behavior

Since that, i did another similar diagram sequence, and it works correctly.
The difference is the type of "Combined Fragment" with "Interaction Operand" i have. I mean, in this one i have a loop type "Combined Fragment" (wich i can't change because of the problem) with an "Interaction Operand", in the other one i have a loop type "Combined Fragment" without the "Interaction Operand" and it works fine.

I hope this can help you.
Attachments:

Please Log in or Create an account to join the conversation.

2 months 6 days ago #5305 by pan
Dear alo,

We found a solution for your problem.

This is some explaination:
At a moment a Message has been deleted but some ghost executionoccurencespecifications stayed in the diagram. When you were trying to do modifications in the model, the diagram was trying to refresh but due to these ghosts it blocked any model modifications.

Please following these steps for fixing the erratic diagram:
- Open the erratic diagram
- Click on the background of the diagram
- Run the attached script. At this step, the ghost objects should be removed. In the script output zone, a message indicating that ghosts have been deleted should appear.
- Save your project

In Modelio 3.8, this will be fixed.

Let me know if it helps.

File Attachment:

File Name: RepairSequ...08-16.py
File Size:1 KB
Attachments:

Please Log in or Create an account to join the conversation.

2 months 2 days ago #5319 by alo
Hi pan,

That's perfect, thank you so much, everything works now.

Please Log in or Create an account to join the conversation.

Moderators: tmaaabcdeebr
Time to create page: 0.238 seconds
^ Back to Top