check [Solved] 3.6.01 To 3.7.01 Error on migration

1 year 1 week ago #4996 by aklopot
I have the same problem. My error is

java.lang.IllegalArgumentException: Unsupported type: class org.modelio.metamodel.uml.behavior.commonBehaviors.EventType

Please help me.
Attachments:

Please Log in or Create an account to join the conversation.

1 year 1 week ago #4998 by cde
Hi aklopot,

We're currently investigating the problem, we'll keep you informed as soon as we have a solution.

Best regards,
cde.
The following user(s) said Thank You: aklopot

Please Log in or Create an account to join the conversation.

1 year 1 week ago #4999 by cde
Hi all,

After investigation, it seems that the problem is related to the ArchiMate plug-in.

So for now, a simple workaround is to deploy the ArchiMate plug-in on your 3.7.1, then the migration will succeed.

Best regards,
cde.

Please Log in or Create an account to join the conversation.

1 year 1 week ago #5000 by aklopot
Hi cde!

It works. Thank you very much. The installation of the current ArchiMate 3.7.1 solved the problem.

Please Log in or Create an account to join the conversation.

1 year 1 week ago #5001 by toggs
Thanks cde!

On a side note, I've never had the ArchiMate plug-in installed. I Installed it, and everything worked as expected.

Don't forget to upgrade the modules: www.youtube.com/watch?v=pdr3iD0A4Bg

Please Log in or Create an account to join the conversation.

Moderators: tmaaabcdeebr
Time to create page: 0.043 seconds
^ Back to Top