file XMI export issue

3 months 6 days ago #4629 by vase
Thank you all the same.

I will try to do the same thing on my personal PC. If I can reproduce it I will send the model to you.

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #4635 by ebr
Did you look at the log file in Help Menu > Open log File.

You are not able to send us our project but would you change an existing jar file in your Modelio installation by a new one (provided by us)?

Cheers,

Etienne

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #4636 by vase
Hi Etienne,

Thank you for your help. I think I can replace the jar file.

By the way, I tried to reproduce the issue today and catch following log. Maybe it will help.
2017-09-19 10:16:26,261 ERROR org.modelio.xmi  - null
java.lang.NullPointerException: null
	at org.modelio.xmi.util.ScopeChecker.contains(ScopeChecker.java:177)
	at org.modelio.xmi.generation.ExportModel.export(ExportModel.java:54)
	at org.modelio.xmi.generation.XMIExportBehavior.visitElementRealization(XMIExportBehavior.java:512)
	at org.modelio.xmi.generation.OwnershipMetamodelVisitor.visitElementRealization(OwnershipMetamodelVisitor.java:758)
	at org.modelio.metamodel.impl.uml.statik.ElementRealizationImpl.accept(ElementRealizationImpl.java:78)
	at org.modelio.metamodel.impl.uml.infrastructure.AbstractionImpl.accept(AbstractionImpl.java:92)
	at org.modelio.xmi.generation.OwnershipMetamodelVisitor.visitModelElement(OwnershipMetamodelVisitor.java:1222)
	at org.modelio.xmi.generation.GenericMetamodelVisitor.visitUmlModelElement(GenericMetamodelVisitor.java:56)
	at org.modelio.metamodel.visitors.DefaultModelVisitor.visitModelTree(DefaultModelVisitor.java:1413)
	at org.modelio.xmi.generation.OwnershipMetamodelVisitor.visitModelTree(OwnershipMetamodelVisitor.java:1237)
	at org.modelio.metamodel.visitors.DefaultModelVisitor.visitNameSpace(DefaultModelVisitor.java:1419)
	at org.modelio.xmi.generation.OwnershipMetamodelVisitor.visitNameSpace(OwnershipMetamodelVisitor.java:1261)
	at org.modelio.metamodel.visitors.DefaultModelVisitor.visitClassifier(DefaultModelVisitor.java:963)
	at org.modelio.xmi.generation.OwnershipMetamodelVisitor.visitClassifier(OwnershipMetamodelVisitor.java:531)
	at org.modelio.metamodel.visitors.DefaultModelVisitor.visitGeneralClass(DefaultModelVisitor.java:1245)
	at org.modelio.xmi.generation.OwnershipMetamodelVisitor.visitGeneralClass(OwnershipMetamodelVisitor.java:933)
	at org.modelio.metamodel.visitors.DefaultModelVisitor.visitClass(DefaultModelVisitor.java:945)
	at org.modelio.xmi.generation.OwnershipMetamodelVisitor.visitClass(OwnershipMetamodelVisitor.java:518)
	at org.modelio.metamodel.impl.uml.statik.ClassImpl.accept(ClassImpl.java:115)
	at org.modelio.metamodel.impl.uml.infrastructure.UmlModelElementImpl.accept(UmlModelElementImpl.java:377)
	at org.modelio.xmi.generation.OwnershipMetamodelVisitor.visitModelTree(OwnershipMetamodelVisitor.java:1239)
	at org.modelio.metamodel.visitors.DefaultModelVisitor.visitNameSpace(DefaultModelVisitor.java:1419)
	at org.modelio.xmi.generation.OwnershipMetamodelVisitor.visitNameSpace(OwnershipMetamodelVisitor.java:1261)
	at org.modelio.metamodel.visitors.DefaultModelVisitor.visitPackage(DefaultModelVisitor.java:1515)
	at org.modelio.xmi.generation.OwnershipMetamodelVisitor.visitPackage(OwnershipMetamodelVisitor.java:1461)
	at org.modelio.metamodel.impl.uml.statik.PackageImpl.accept(PackageImpl.java:200)
	at org.modelio.metamodel.impl.uml.infrastructure.UmlModelElementImpl.accept(UmlModelElementImpl.java:377)
	at org.modelio.xmi.generation.ExportServices.createEcoreModel(ExportServices.java:178)
	at org.modelio.xmi.gui.ExportThread.run(ExportThread.java:67)
	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:119)

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #4637 by ebr
Hi vase,

Your log was more than helpfull!!!
Your issue is now fixed and will delivered in the next version of Modelio (3.7) coming soon.

Your issue comes from the export of one ElementRealization element.
In order to check if it is the only issue could you try to delete all of them and reexport your model.

Many thanks in advance,

EBR

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #4638 by vase
Hi EBR

I deleted the realization connection, and export my project successfully.
Thank you for your help.

Please Log in or Create an account to join the conversation.

2 months 3 weeks ago #4639 by ebr
Hi again Vase,

That's good news. As I said, the fix will be delivered with the next release of Modelio.
Hoping this is not too critical for you.

Cheers,

EBR
The following user(s) said Thank You: vase

Please Log in or Create an account to join the conversation.

Moderators: tmaaabcdeebr
Time to create page: 0.033 seconds
^ Back to Top