Submit a problem

In order to provide you the best help possible to analyze and debug your problems please provide us some information about your environment.
When you submit a problem, please indicate:
- The Version, Build Id, Core Id, System and Architecture (You can get these information in the Help/About menu entry)
- The Modelio Edition (Modelio Open Source or Modelio by Modeliosoft)
- Your Operating System

check When upgrading a project from Modelio 3.4 to 3.6.1 Diagrams Outline is empty

1 month 3 days ago - 4 weeks 1 day ago #4490 by mihaido
Hello,

I have a project which contains a rather large diagram.
I upgraded from Modelio 3.4 to 3.6.1 and the Outline is all blank. Is there any way to fix this?
Without the outline I find it very difficult to navigate the diagram, and it is very annoying that a minor update will break my project.

Thanks,
Mihai

Please Log in or Create an account to join the conversation.

1 month 3 days ago #4491 by pan
Hi,

Please could you share your project with us?

BR

Please Log in or Create an account to join the conversation.

1 month 19 hours ago #4492 by mihaido
Attaching a modified, converted project. I cannot attach the 3.4 project because it has 2 MB and your site does not allow more than 1.5.

File Attachment:

File Name: AS3.6.01.zip
File Size:1,068 KB
Attachments:

Please Log in or Create an account to join the conversation.

1 month 18 hours ago #4493 by pan
Maybe you could upload your project (version 3.4) on wetransfer or any other sharing service and share the link with us?

Please Log in or Create an account to join the conversation.

1 month 11 hours ago #4494 by mihaido
Try this link:

we.tl/zIzB0HTczQ

Please Log in or Create an account to join the conversation.

1 month 10 hours ago #4495 by pan
Thanks.

Finally we reproduced the problem. Actually it is not a migration problem. Even on new 3.6 projects we can reproduce it.
It seems that the problem occurs with large diagrams.
Between Modelio 3.4 and 3.6.1 we have updated an Eclipse graphic library (gef). This new version of gef is the cause of the problem.
We will investigate on how to fix this.

BR

Please Log in or Create an account to join the conversation.

Moderators: tmaaabcdeebr
Time to create page: 0.060 seconds
^ Back to Top