question-circle Questions in terms of setting up Modelio development environment in Eclipse

7 years 1 week ago #3553 by fajia
I am new who are researching Modelio development. There are some problems I have encountered during building up the development environment in Eclipse.
I downloaded the Modelio source, and started a new Modelio development by following this guide .
First of all, there are many dependency errors in the area where it is modelio-os.product.


Secondly, when I attempted to create a new product, there is not defining plugin of org.modelio.app.ui displaying in the selection list.


but I have the app.ui plugin in my eclipse environment



The log is as below when I click the Launch an Eclipse application button.

!SESSION 2015-08-05 23:19:06.479
eclipse.buildId=unknown
java.version=1.8.0
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_AU
Framework arguments: -product org.modelio.app.ui.modelio -clearPersistedState
Command-line arguments: -product org.modelio.app.ui.modelio -data F:\eclipse-jee-luna-SR2-win32-x86_64\eclipse\workspace/../runtime-modelio-os.product -dev file:F:/eclipse-jee-luna-SR2-win32-x86_64/eclipse/workspace/.metadata/.plugins/org.eclipse.pde.core/modelio-os.product/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog -clearPersistedState

!ENTRY org.eclipse.equinox.app 0 0 2015-08-05 23:19:07.767
!MESSAGE Product org.modelio.app.ui.modelio could not be found.

!ENTRY org.eclipse.osgi 2 0 2015-08-05 23:19:08.143
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2015-08-05 23:19:08.144
!MESSAGE Bundle reference:file:/C:/Users/David Fa/Downloads/modelio_sources_3.1.0/modelio_sources/RCPTARGET/eclipse/plugins/org.eclipse.help.ui_4.0.0.v20130515-1955.jar was not resolved.
!SUBENTRY 2 org.eclipse.help.ui 2 0 2015-08-05 23:19:08.145
!MESSAGE Missing required bundle org.eclipse.ui.forms_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2015-08-05 23:19:08.145
!MESSAGE Bundle reference:file:/C:/Users/David Fa/Downloads/modelio_sources_3.1.0/modelio_sources/RCPTARGET/astyle/plugins/org.modelio.astyle.win32.win32.x86_64_1.23.0.jar was not resolved.
!SUBENTRY 2 org.modelio.astyle.win32.win32.x86_64 2 0 2015-08-05 23:19:08.146
!MESSAGE Missing host org.modelio.api_1.0.0.

!ENTRY org.eclipse.osgi 2 0 2015-08-05 23:19:08.152
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2015-08-05 23:19:08.152
!MESSAGE Bundle org.eclipse.help.ui_4.0.0.v20130515-1955 [72] was not resolved.
!SUBENTRY 2 org.eclipse.help.ui 2 0 2015-08-05 23:19:08.154
!MESSAGE Missing required bundle org.eclipse.ui.forms_[3.5.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2015-08-05 23:19:08.155
!MESSAGE Bundle org.modelio.astyle.win32.win32.x86_64_1.23.0 [90] was not resolved.
!SUBENTRY 2 org.modelio.astyle.win32.win32.x86_64 2 0 2015-08-05 23:19:08.156
!MESSAGE Missing host org.modelio.api_1.0.0.

!ENTRY org.eclipse.osgi 4 0 2015-08-05 23:19:08.159
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
at org.eclipse.equinox.launcher.Main.run(Main.java:1450)
at org.eclipse.equinox.launcher.Main.main(Main.java:1426)
Attachments:

Please Log in or Create an account to join the conversation.

6 years 9 months ago #3718 by ebr
Hi,

In order to solve your dependency issue, did you configure the target definition?
Cf Modelio compile

Best,

EBR

Please Log in or Create an account to join the conversation.

Moderators: tmaaabcde
Time to create page: 1.584 seconds
^ Back to Top