map-pin [Solved] Does not open in Mac

5 years 4 months ago #2440 by ffe
Hi scribnar,

From the log

java.version=1.6.0_65
java.vendor=Apple Inc.


According to the log, it seems Java 7 is not correctly installed.
Please, could you check into "System Preferences" if the option java is available ?
Also, if you open a terminal which java version is used when you run the following command: "java -version"

You can find a tip in our faq at this address:
www.modelio.org/documentation/faq-menu.html (How to make Modelio 3 work on MacOS X (version prior to 10.7.3) )

best regards,

Please Log in or Create an account to join the conversation.

5 years 4 months ago #2441 by scribnar
Thanks for the reply. I get the below reply when I type java -version in terminal.

java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

Java control panel from system preferences shows Java 7 Update 51. Can I use the steps given for this also?

Is Modelio tested in Mac at all? The reason I am asking is that its not working in one of my colleagues Macbook Pro also.

Please Log in or Create an account to join the conversation.

5 years 4 months ago #2442 by ffe
Hi Scribnar,

Modelio 3.1 has been tested on a Mac OS X 10.8.5
I suggest you to follow the steps in the faq to use JDK 1.7 as preferred JRE.

Best regards,

Please Log in or Create an account to join the conversation.

5 years 3 months ago - 5 years 3 months ago #2453 by cde
Hi,

Modelio 3.1 has now been validated on Mac OS 10.9.1 too.

N.B. A JDK 1.7 is mandatory for Modelio to works on Mac OS, a simple JRE 1.7 is not enough.
You can download the JDK 1.7 dmg at oracle.com .

Best regards,
cde

Please Log in or Create an account to join the conversation.

5 years 3 months ago #2457 by scribnar
Thank you both a lot. It works great after installing JDK.

Cheers.

Please Log in or Create an account to join the conversation.

5 years 3 months ago #2486 by scribnar
I had to reinstall the OS due to some other issues. After that I restored the computer using TimeMachine backup.

I was asked to install Java when I opened it and it installed both JRE automatically. Later I installed JDK. Now I get the below error when I try to open it. This error is in a file /Users/Scribnar/.eclipse/820897768_macosx_cocoa_x86_64/configuration/1391582961107.

I don't find any way to choose the Java version in the latest Mac which is 10.9.1. Any help is greatly appreciated as I tried multiple options and it's not working still.

!SESSION 2014-02-05 12:19:20.894
eclipse.buildId=unknown
java.version=1.7.0_51
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments: -clearPersistedState -keyring /Users/scribnar/.eclipse_keyring -showlocation
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -clearPersistedState -keyring /Users/scribnar/.eclipse_keyring -showlocation

!ENTRY org.eclipse.osgi 4 0 2014-02-05 12:19:21.433
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:354)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:181)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:636)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:591)
at org.eclipse.equinox.launcher.Main.run(Main.java:1450)

Please Log in or Create an account to join the conversation.

Moderators: tmaaabcdeebr
Time to create page: 0.040 seconds
^ Back to Top