file [Solved] Communication Link

8 years 10 months ago #2088 by ebr
Hi,

Concerning your issue with the audit I would explicitly launch a "model checking" (by using the "check model" command in the contextual menu) in order to be sure that the actual status of the model is checked. We would give you more information if you could send us your project.

The Communication Link are configurable through the Diagram style editor by modifying Association settings.

Hoping it helps,

EBR

Please Log in or Create an account to join the conversation.

8 years 10 months ago #2091 by SukmanovaDarya
Thanks for second answer, that's right.

About first question. Checking model doesn't help. Show you my project before and after closin it and opening it again without changes. Something is in Russian, but I think it doesn't matter - you can see thet warning is wrong.
Attachments:

Please Log in or Create an account to join the conversation.

8 years 10 months ago #2092 by ebr
You checked your model before closing it and after re opening it?

Please Log in or Create an account to join the conversation.

8 years 10 months ago #2093 by SukmanovaDarya
Yes:)

Please Log in or Create an account to join the conversation.

5 years 10 months ago - 5 years 10 months ago #4231 by franckb
I've the same issue.
I created an generic user ; let's call it UniversityUser.
I've 2 others actors, Teacher and Student. In a UC diagram, I described Student a

As some basic operations (as authenticate) are accessible to Teacher and Student:
+ I created a generalization link between Student and UniversityUser
+ I created a generalization link between Teacher and UniversityUser
+ I created a communication link between UniversityUser and the basic operations

As soon as I've done this, I got R1990 warnings on Teacher and Student.
Is it normal ?
How to describe correctly without linking any basic operations to all kinds of UniversityUser ?

Please Log in or Create an account to join the conversation.

5 years 10 months ago #4232 by ebr
Hi,

I tried to reproduce your issue with latest version of Modelio cf attached screenshot and I do not have any complain from the audit.
Which version of Modelio do you use? Don't you have several communication link between the same Acteur and UseCase?

Cheers,

Attachments:

Please Log in or Create an account to join the conversation.

Moderators: tmaaabcde
Time to create page: 0.157 seconds
^ Back to Top