question-circle BUILD Binaries from sources

7 years 4 months ago #566 by ffe
Hi Yaugze,

Don't worry about the modelio.xml content. This ant file is used in internal to product a jar file.
Please, could you give us the used jre and the used eclipse (platform and architecture). It is for information only.

Moreover on the command line I can see "-os linux -ws gtk -arch x86" which is incorrect in my case. I must have forget to replace linux by freebsd somewhere. Do you have any idea where it could be?


You see this message when either you are running Modelio under Eclipse or you are running Modelio after to export the product.

I also remark:
When I type the following command on the workspace "find ./ -name "*org.modelio.api*" I get nothing! Eclipse does not complain any error though.


If you search the plugin ID "org.modelio.api", it is the plugin project "api" on the workspace.

Please Log in or Create an account to join the conversation.

7 years 4 months ago #573 by yaugze
Hi ffe,

Many thanks for helping me having Modelio running on my Computer!

I made some significant progress last week:
- In the "Window => Preferences => Target Platform" dialog and removed the previously created target. I use now the "native" one which is compatible with my OS and architecture (FreeBSD 64 bit)
- I recompiled libAStylej.so from source (because it was a 32 bit version).
- I replaced all dependencies "org.eclipse.swt.gtk.linux.x86.jar" by "org.eclipse.swt.gtk.freebsd.amd64.jar"

Then I tried to launch Modelio by clicking on the link "Launch an Eclipse Application" in the product file, but it failed...

I saw an interresting message saying that it wasn't possible to load the 64 bit "org.eclipse.swt.gtk.freebsd.amd64.jar" on a 32 bit JVM.
=> I must have missing something to switch the proect to 64 bit...

Don't worry about the modelio.xml content. This ant file is used in internal to product a jar file.


Ok.

Please, could you give us the used jre and the used eclipse (platform and architecture). It is for information only.


I use eclipse 3.7.0 with OpenJDK 7 on FreeBSD AMD64.

You see this message when either you are running Modelio under Eclipse or you are running Modelio after to export the product.


When I running Modelio under Eclipse (in the Console View).

best regards,
Fabien

Please Log in or Create an account to join the conversation.

Moderators: chmcma
Time to create page: 0.032 seconds
^ Back to Top