file Maven error when building&packaging modelio from source

5 years 6 months ago #2225 by jmfavre
Hi,
I'm trying to build modelio 3 from sources.
I've managed successfully to compile and execute modelio thanks to the instructions provided here :up But in the package phase with maven I get this error when I try "mvn compile" :oops:
Exception in thread "main" java.lang.NoSuchMethodError: org.apache.maven.execution.MavenSession.getRepositorySession()Lorg/sonatype/aether/RepositorySystemSession;
        at org.eclipse.tycho.core.maven.utils.PluginRealmHelper.execute(PluginRealmHelper.java:92)
        at org.eclipse.tycho.p2.resolver.P2TargetPlatformResolver.getDependencyMetadata(P2TargetPlatformResolver.java:144)
        at org.eclipse.tycho.p2.resolver.P2TargetPlatformResolver.setupProjects(P2TargetPlatformResolver.java:126)
        at org.eclipse.tycho.core.resolver.DefaultTychoDependencyResolver.setupProject(DefaultTychoDependencyResolver.java:87)
        at org.eclipse.tycho.core.maven.TychoMavenLifecycleParticipant.afterProjectsRead(TychoMavenLifecycleParticipant.java:77)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:271)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:152)
        at org.apache.maven.cli.MavenCli.execute(MavenCli.java:555)
        at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:214)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:158)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:606)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
Any idea? Which version of maven are you using exactly?
Thanks in advance,
Jean-Marie

Please Log in or Create an account to join the conversation.

5 years 6 months ago - 5 years 6 months ago #2226 by jmfavre
Ok, with further investigation the problem is actually due to the version of maven.
Not working with 3.1.1 but with 3.0.5 "mv compile" and "mv package" run like a charm.

BTW this message should go in the "Development / Core". Sorry :oops:

Please Log in or Create an account to join the conversation.

5 years 6 months ago #2242 by chm
No problem, I'm moving the topic to the appropriate section.

Please Log in or Create an account to join the conversation.

Moderators: chmcma
Time to create page: 0.036 seconds
^ Back to Top