lock [Solved] Plugin Usage

7 years 10 months ago - 7 years 10 months ago #587 by chm
Hi,

just tried downloading and using the templatemoduleproject from the wiki too.
Had to fill the generated IDs in module.xml to make it deployable, like you did, i guess. (Maybe you forgot a few?)

With the MDA -> "activate/deactivate module" command, you should be able to confirm wheter your module is deployed and active or not.

If active, right clicking on the root of the "Model" view (or any other model element) should display your hello command in a submenu named after your module...
By the way, the module label is defined in the module.properties file.
The topic has been locked.
7 years 10 months ago - 7 years 10 months ago #588 by mersa
hey,

yes, i forgot to say that i inserted some uids in the module.xml (four i guess).
i select the jmdac in MDA -> "install", but it doesn´t show up in MDA -> "activate/deactivate module"
but at least, now i know that there is a mistake on my site. thanks for trying :)

Edit: the good thing is, that it finally works, the bad thing is, that i couldn´t identify the problem, anyway, now i have a handy basis to work on and do some self-study.
thanks again for the help. i definitely come back to you at some point ;)
The topic has been locked.
7 years 9 months ago #594 by mersa
Hey,

i´m at a point where it would be comfortable to debug a module. There is a short tutorial in the wiki 'Debugging the module with Eclipse'. Unfortunately it´s to short for me.
I have the modelio source and the module source in eclipse.
Could anyone explain me

..you have to deploy the Plug-ins Development Environment (PDE) as plug-in in Eclipse..

in more detail?
The topic has been locked.
7 years 9 months ago #597 by chm
Well, i guess you have to follow a little the link from the wiki:

I am currently using Eclipse SDK 3.7.1 , containg all needed plugins to work with modules.

Hope this helps!
The topic has been locked.
7 years 9 months ago - 7 years 9 months ago #600 by mersa
i´m sorry but i´m stucked

so let´s go back to the most handy scenario possible:

i want to debug the helloworld module mentioned above and stick closly to the 'ModelioModuleDevelopmentTutorial pour Modelio 1.1.pdf'

- i´m using a plain eclipse instance
- the hw template is in my workspace
- under preferences->plugin->targetplatform, i add another target,
location is my modelio application folder (tried both Modelio EE
10day trial and the version provided here)
- i create a new run configuration -> run


!SESSION 2012-03-20 14:49:47.386 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_02
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Framework arguments:  -product org.modelio.branding.modelio
Command-line arguments:  -product org.modelio.branding.modelio -data D:\eclipse-modeling-indigo-SR2-win32\workspace/../runtime-Modelio(2) -dev file:D:/eclipse-modeling-indigo-SR2-win32/workspace/.metadata/.plugins/org.eclipse.pde.core/Modelio(2)/dev.properties -os win32 -ws win32 -arch x86 -consoleLog

!ENTRY org.eclipse.ui 2 0 2012-03-20 14:49:48.810
!MESSAGE Warnings while parsing the key bindings from the 'org.eclipse.ui.commands' extension point
!SUBENTRY 1 org.eclipse.ui 2 0 2012-03-20 14:49:48.810
!MESSAGE Cannot bind to an undefined command: plug-in='org.modelio.diagram.editor', id='com.modeliosoft.modelio.CreateElementCommand'

!ENTRY org.modelio.core 1 0 2012-03-20 14:49:48.933
!MESSAGE Loading LibModelio.

!ENTRY org.modelio.core 1 0 2012-03-20 14:49:48.956
!MESSAGE LibModelio loaded successfully.

!ENTRY org.modelio.core 1 0 2012-03-20 14:49:49.045
!MESSAGE Modelio core successfully started.
- 14:49:49,046 INFO org.modelio.core:Modelio core successfully started.

A modelio instance open but unfortunately with very little functionality.

I know that it is hard to follow my explanations, but do you have any hints? Is this basically the right procedure or am i missing an important point?

Edit:

To be more precise:
I don´t know how to adress the
'!MESSAGE Cannot bind to an undefined command: plug-in= 'org.modelio.diagram.editor', id='com.modeliosoft.modelio.CreateElementCommand'' - message.

And how do i finally debug my example module?
The topic has been locked.
7 years 9 months ago #604 by chm
Hi mersa,

First of all, you should look at the wiki rather than the pdf, its content should be a little more accurate.

I tried downloading a new eclipse, using a new workspace containg the project template, and strictly following the tutorial step by step. Worked fine for me... Maybe you missed something, like filling a field somewhere?

Most messages you quoted from eclipse's console are ok, they just come from launching Modelio. The "undefined command" one is more intriguing, looks like your configuration misses some plugins...

Could you please try the following steps?
- under preferences->plugin->targetplatform, make sure your "Modelio" target is checked.
- edit the "Modelio" target.
- in the "Content" tab, make sure all plugins are selected.
- edit the run configuration you created
- in "plug-ins" tab, the "Launch with" combo should indicate "all workspace and enabled target plug-ins"

And just to be sure, what operating system are you running on?
The topic has been locked.
Moderators: tmachmaab
Time to create page: 0.044 seconds
^ Back to Top