lock [Solved] Plugin Usage

8 years 3 days ago #706 by chm
Oh, this is a little error on the wiki, sorry: "libmodelio.so" is for linux, and "modelio.dll" for windows, so it seems you're good with that.

Skipping the 'Install the Modelio Core Library' part is the right thing to do, as you don't want to change the C++ part at all.
The topic has been locked.
8 years 3 days ago - 8 years 3 days ago #707 by mersa
That is what i thought, but since the modelio.dll is already deployed with the sources i don't need to do anything.


Anyway i'm a bit confused because i'm not doing any preliminary work before step six. Where is my c++ part aside from the modelio.dll?

Edit:
this might be a quite usefull information, sorry..
Caused by: java.lang.UnsatisfiedLinkError: D:\ModelioSources\modelio.plugins\corelib.win32.win32.x86\lib\modelio.dll: Can't find dependent libraries
The topic has been locked.
8 years 3 days ago - 8 years 3 days ago #708 by fpo
Basically, the system is telling you that it tried to load modelio's dll, but couldn't due to other dll's missing/not found.
The good news is that it means that at least some of the java code of Modelio has been executed, since the loading of the dll is done in the "core" plugin.
The bad news is that it isn't telling us what libraries are missing...

My guess is that the debug version of some system libraries are needed, because the dll that is deployed with the sources is probably a debug one (compiled with debug flags, and using debug libraries). These debug libraries are usually provided by the compilation environment (visual studio, etc).

But since you don't really need nor want to debug the C++ part, I say you could probably try to switch the dll deployed with the sources with the dll from your modelio installation. That last one should be a "release" dll, using "standard" libraries that should be present on your system.
The topic has been locked.
8 years 3 days ago #710 by mersa
sounds comprehensible but replacing the modelio.dll shows no effect. I'll keep on digging for a solution..
The topic has been locked.
8 years 3 days ago #711 by ffe
Hi Mersa,

The modelio library depends of dll which are stocked in
modelio.plugins\FEATURE - bundled files\windows_files
In order to resolve the "Can't find dependent libraries " error, you can to try to copy all these dll in into root of your eclipse tool.
The topic has been locked.
7 years 11 months ago #731 by mersa
Hey,

this advice sounds good, unfortunately it doesn't help. I continue digging for a solution and keep you informed about my progress.

Thank you so far for your patience and help :)
The topic has been locked.
Moderators: tmachmaab
Time to create page: 0.066 seconds
^ Back to Top