file metamodel problem with modelio 3.0

3 years 4 months ago #4252 by besma
Hi,
I developped a module with the code source of modelio 3.0.
Later, i wanted to continue the developpemnt on this version but eclipse when it buil the projet , it deos not find some classes and packages.
I see also that the maven works with the latest version for jar that is 3.5.

How can I work with only modeler modelio jar for 3.0 version not 3.5.
the archetype when I maked the project is 3.0.0

Any idea please.

Please Log in or Create an account to join the conversation.

3 years 3 months ago #4264 by ffe
Hi,

Edit your module pom.xml file and search for the MDAKit dependency. You should find the following block:
		<dependency>
			<groupId>org.modelio</groupId>
			<artifactId>MDAKit</artifactId>
			<version>[3.0.0,)</version>
			<type>pom</type>
			<scope>provided</scope>
		</dependency>
The version range of this dependency must be modified to: [3.0.0,3.1.0)
After the modification, the block should be:
		<dependency>
			<groupId>org.modelio</groupId>
			<artifactId>MDAKit</artifactId>
			<version>[3.0.0,3.1.0)</version>
			<type>pom</type>
			<scope>provided</scope>
		</dependency>

best regards,

Please Log in or Create an account to join the conversation.

Moderators: tmachmaab
Time to create page: 0.059 seconds
^ Back to Top