file How to build the development environment for Modelio?

4 years 7 months ago #3509 by templezy
There is not any selection in the list.

Please Log in or Create an account to join the conversation.

4 years 7 months ago #3510 by ebr
Even if you type "org.modelio" or just "org" inside?

Attachments:

Please Log in or Create an account to join the conversation.

4 years 7 months ago #3512 by templezy
Yes, i just type the 'org' in the blanket, there isnt any items i can choose.
Attachments:

Please Log in or Create an account to join the conversation.

4 years 7 months ago #3513 by ebr
You have this app.ui plugin project in your explorer, but it does not appear in the plugin search, right?
Do you have any error, problem?

Please Log in or Create an account to join the conversation.

4 years 7 months ago #3514 by templezy
I just configure it again it has showed in the menu. But when i click the Launch button, there are several errors in the console.
!SESSION 2015-06-06 00:05:45.149 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_25
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86, WS=cocoa, NL=en_US
Framework arguments:  -product org.modelio.app.ui.modelio -clearPersistedState
Command-line arguments:  -product org.modelio.app.ui.modelio -data /Users/alex/Documents/wpformodelio/../runtime-modelio-os.product -dev file:/Users/alex/Documents/wpformodelio/.metadata/.plugins/org.eclipse.pde.core/modelio-os.product/dev.properties -os macosx -ws cocoa -arch x86 -consoleLog -clearPersistedState

!ENTRY org.eclipse.equinox.app 0 0 2015-06-06 00:05:46.075
!MESSAGE Product org.modelio.app.ui.modelio could not be found.

!ENTRY org.eclipse.help.ui 4 0 2015-06-06 00:05:46.112
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.help.ui [471]
  Unresolved requirement: Require-Bundle: org.eclipse.ui.forms; bundle-version="[3.5.0,4.0.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.modelio.astyle.macosx.cocoa.x86 2 0 2015-06-06 00:05:46.233
!MESSAGE Could not resolve module: org.modelio.astyle.macosx.cocoa.x86 [491]
  Unresolved requirement: Fragment-Host: org.modelio.api; bundle-version="1.0.0"


!ENTRY org.eclipse.help.ui 2 0 2015-06-06 00:05:46.234
!MESSAGE Could not resolve module: org.eclipse.help.ui [471]
  Unresolved requirement: Require-Bundle: org.eclipse.ui.forms; bundle-version="[3.5.0,4.0.0)"


!ENTRY org.eclipse.osgi 4 0 2015-06-06 00:05:46.236
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
	at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
	at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:483)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1438)
gogo: InterruptedException: sleep interrupted
java.lang.InterruptedException: sleep interrupted
	at java.lang.Thread.sleep(Native Method)
	at org.apache.felix.gogo.shell.Activator.run(Activator.java:72)
	at java.lang.Thread.run(Thread.java:745)
An error has occurred. See the log file
/Users/alex/Documents/wpformodelio/.metadata/.plugins/org.eclipse.pde.core/modelio-os.product/1433514945351.log.

Please Log in or Create an account to join the conversation.

Moderators: tmachmaab
Time to create page: 0.225 seconds
^ Back to Top