file [JavaDesigner] Issu with Javadoc and type String

4 years 9 months ago #3366 by RomainH
Hi,

i'm new with Modelio but i didnt find an answer in internet, so i ask here.

I'm trying the module javaDesigner and i have two problem :

the first one is that when i reverse my code, he don't understand the type "String" (see the two attachments) and i don't understand why because when i'm on Modelio, i use ctrl + space and he propose "string", then i generate java code, i add one string attribute then i reverse, and he doesn't understand "string" as you can see in the first print screen :/.

The second issue is less important but i don't understand why i get it. When i click on "generate javadoc" (which is activate) i get a error message, as you can see in the third print screen.

Well sorry for the mistakes, i'm not english and Thank you in advance!

Have a nice day.
Attachments:

Please Log in or Create an account to join the conversation.

4 years 8 months ago - 4 years 8 months ago #3381 by pan
Hi RomainH,

First of all, you need to configure the JDK path in the JavaDesigner module settings.( How to set the JDK path ) Are you using the JDK 8?
Then, you need to configure the accessible classes for the reverse so the module can find the right types. ( How to define the classpath for the reverse of java code ). For the JDK types, you should give the path to the rt.jar library (in the $JRE_PATH/lib/ directory).

Let us know if it helps.

Please Log in or Create an account to join the conversation.

4 years 8 months ago #3384 by RomainH
Hi pan,

First of all, thank you for your answer.

My first problem is totaly solve, thanks for that.

Do you have any idea for the second ?

Thank you in advance!

Please Log in or Create an account to join the conversation.

4 years 8 months ago #3385 by pan
For the problem of javadoc generation, it's because the JDK is not found. the javadoc.exe is found relatively to the JDK path so if you have correctly configured the JDK path (not the JRE) it should work.
The following user(s) said Thank You: RomainH

Please Log in or Create an account to join the conversation.

4 years 8 months ago #3386 by RomainH
Okok, i think i see the problem.

Thanks for all.

Best regards.

Please Log in or Create an account to join the conversation.

Moderators: tmachmaab
Time to create page: 0.041 seconds
^ Back to Top